Closed Bug 1540628 Opened 8 months ago Closed 7 months ago

Long press of Backspace key of ATOK removes only one character

Categories

(Firefox for Android :: Keyboards and IME, defect, P1, critical)

Firefox 67
ARM
Android
defect

Tracking

()

RESOLVED FIXED
Firefox 68
Tracking Status
firefox66 --- unaffected
firefox67 + fixed
firefox68 + fixed

People

(Reporter: masayuki, Assigned: m_kato)

References

(Regression)

Details

(Keywords: inputmethod, jp-critical, regression)

Attachments

(1 file)

[Tracking Requested - why for this release]: Really annoying regression.

Probably this is a regression of bug 1495985. I cannot reproduce this bug with other vendors' IME.

STR:

  1. Select ATOK Passport or ATOK Passport Professional
  2. Type something into <input> element or somewhere
  3. Press "Backspace" key of the virtual keyboard and keep pressing for a while

AR:
Only the previous one character is removed.

ER:
Removing previous characters repeatedly.

I guess that resetting state of ATOK causes this.

Assignee: nobody → m_kato

I guess that resetInput implementation of ATOK is async, then updateSelection won't work unfortunately....

Priority: -- → P1

Makoto, do you have an update for this regression?

Flags: needinfo?(m_kato)

(In reply to Pascal Chevrel:pascalc from comment #2)

Makoto, do you have an update for this regression?

I am still looking for another workaround to fix this. bug 1495985 is for 3rd party application bug.

Flags: needinfo?(m_kato)

As of my feeling, backing out is better than this bug if you cannot fix this by the 67 release.

Since restartInput resets all keyboard state, it isn't good to call this
everytime. So we should call this when discarding composition only.

Pushed by m_kato@ga2.so-net.ne.jp:
https://hg.mozilla.org/integration/mozilla-inbound/rev/2e9187dc17a9
Don't use restartInput when no composition. r=esawin
Status: NEW → RESOLVED
Closed: 7 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 68

Makoto, is this fix safe for uplift to beta or would it be safer to back out bug 1495985?

No longer blocks: 1495985
Flags: needinfo?(m_kato)
Regressed by: 1495985

Comment on attachment 9058227 [details]
Bug 1540628 - Don't use restartInput when no composition.

Beta/Release Uplift Approval Request

  • User impact if declined: When using ATOK input method (this is no-free product) on Android, repeating [backspace] key doesn't work.
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): This workaround is for ATOK only. I change the timing to reset input method on ATOK. When removing all composing string on ATOK, restart input method.
  • String changes made/needed:
Flags: needinfo?(m_kato)
Attachment #9058227 - Flags: approval-mozilla-beta?

Comment on attachment 9058227 [details]
Bug 1540628 - Don't use restartInput when no composition.

Workaround for a P1 regression in 67, uplift approved for 67 beta 15, thanks.

Attachment #9058227 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
You need to log in before you can comment on or make changes to this bug.