Wierd character  in email text instead of double space.

RESOLVED INVALID

Status

RESOLVED INVALID
17 years ago
14 years ago

People

(Reporter: evant, Assigned: sspitzer)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.0.0) Gecko/20020530
BuildID:    2002053012

I find that sometimes I see a wierd character - Â - in email text instead of
double space.  Surely, If I am using HTML as my email message format, then it
would be better if the editor recorded all consecutive space characters, bar the
ultimate space character, as  

Reproducible: Sometimes
Steps to Reproduce:
1.Create an email message with consecutive space characters.
2.It seems to happen more frequently if you have changed the text formatting and
text styles often as you have composed the email message.
3.Send the email to yourself and others
4.Notice that in the received email the consecutive spaces are rendered as Â
characters.  That is ÂÂÂÂÂÂ

Comment 1

17 years ago
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.0.0) Gecko/20020530
I could not reproduce your problem, but I often have similar problems (also
difficult to reproduce)

Comment 2

16 years ago
What character set is being used?  It sounds like the non-breaking space
character is being converted incorrectly.

Comment 3

16 years ago
Evan Toliopoulos, is this bug still an issue for you?  I am unable to get a mail 
with nbsp's enclosed to display as described, picking any encoding.  If I save 
the mail as a .eml file, I can see the strange character in dumb viewer programs 
that don't understand encoding, but Mozilla (1.3, 1.4) seems to be doing the 
right thing no matter how I try to view it.

Comment 4

16 years ago
=>Invalid, no response from reporter.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.