toolchain 'stable-x86_64-unknown-linux-gnu' does not contain component 'rust-std' for target 'thumbv7neon-linux-androideabi'

RESOLVED FIXED in Firefox 68

Status

()

defect
P1
normal
RESOLVED FIXED
2 months ago
2 months ago

People

(Reporter: bdekoz, Assigned: glandium)

Tracking

Trunk
Firefox 68
x86_64
Linux
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox68 fixed)

Details

Attachments

(1 attachment)

Reporter

Description

2 months ago

Using m-c from today, and attempting a './mach bootstrap' build for arm-android (non-archive) fails on a fedora-29 (x86-64/linux) host. Archive builds are fine.

The error message:

We are now installing the following Android packages:
platform-tools
build-tools;27.0.3
platforms;android-28
emulator

You may be prompted to agree to the Android license. You may see some of
output as packages are downloaded and installed.

Warning: File /home/bkoz/.android/repositories.cfg could not be loaded.
[=======================================] 100% Computing updates...
Your version of Mercurial (4.5.3) is sufficiently modern.
Your version of Python (2.7.15) is new enough.
Your version of Rust (1.32.0) is new enough.
Rust supports aarch64-linux-android, armv7-linux-androideabi, i686-linux-android, x86_64-linux-android, x86_64-unknown-linux-gnu targets.
error: toolchain 'stable-x86_64-unknown-linux-gnu' does not contain component 'rust-std' for target 'thumbv7neon-linux-androideabi'
Error running mach:

['bootstrap']

The error occurred in code that was called by the mach command. This is either
a bug in the called code itself or in the way that mach is calling it.

You should consider filing a bug for this issue.

If filing a bug, please include the full output of mach, including this error
message.

The details of the failure are as follows:

CalledProcessError: Command '[u'/home/bkoz/.cargo/bin/rustup', u'target', u'add', u'thumbv7neon-linux-androideabi']' returned non-zero exit status 1

File "/home/bkoz/src/mozilla-gecko.target.git/python/mozboot/mozboot/mach_commands.py", line 43, in bootstrap
bootstrapper.bootstrap()
File "/home/bkoz/src/mozilla-gecko.target.git/python/mozboot/mozboot/bootstrap.py", line 434, in bootstrap
self.instance.ensure_rust_modern()
File "/home/bkoz/src/mozilla-gecko.target.git/python/mozboot/mozboot/base.py", line 676, in ensure_rust_modern
self.ensure_rust_targets(rustup)
File "/home/bkoz/src/mozilla-gecko.target.git/python/mozboot/mozboot/base.py", line 721, in ensure_rust_targets
subprocess.check_call([rustup, 'target', 'add', target])
File "/usr/lib64/python2.7/subprocess.py", line 190, in check_call
raise CalledProcessError(retcode, cmd)
<bkoz@varney> /home/bkoz/src/mozilla-gecko.target.git

glandium: does Bug 1539005 secretly rely on a newer Rust, i.e., Rust 1.33+? Is there something else going on here?

Depends on: 1539005
Flags: needinfo?(mh+mozilla)
Assignee

Updated

2 months ago
Flags: needinfo?(mh+mozilla)
Assignee

Comment 2

2 months ago

Bootstrap is happy with rust version 1.32, but that version of rust
doesn't support the thumbv7neon target that we're trying to install
since bug 1539005. So install the armv7 target when rust is version
1.32.

Reporter

Comment 3

2 months ago

thanks for the hint Nick!

rustup update

makes it work, and as a bonus removes the '+neon ignored' warnings from the archive build...

Comment 4

2 months ago
Pushed by mh@glandium.org:
https://hg.mozilla.org/integration/autoland/rev/e9bbe52bbd8d
Make mach bootstrap choose arm target depending on the rust version. r=nalexander
Assignee: nobody → mh+mozilla
Priority: -- → P1

Comment 5

2 months ago
bugherder
Status: NEW → RESOLVED
Last Resolved: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 68
Duplicate of this bug: 1541112

Backed out on request from glandium changeset e9bbe52bbd8d (bug 1540788) for breaking bootstrap. a=backout

Backout link: https://hg.mozilla.org/mozilla-central/rev/a53585c83f44d09c2d7f29e07af5d426a7f61084

Flags: needinfo?(mh+mozilla)
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Target Milestone: Firefox 68 → ---
Assignee

Comment 8

2 months ago

The problem is that rust_version is already a LooseVersion, so LooseVersion(rust_version) fails.

Comment 9

2 months ago
Pushed by mh@glandium.org:
https://hg.mozilla.org/integration/autoland/rev/0d79b33ce381
Make mach bootstrap choose arm target depending on the rust version. r=nalexander

Comment 10

2 months ago
bugherder
Status: REOPENED → RESOLVED
Last Resolved: 2 months ago2 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 68
Assignee

Updated

2 months ago
Flags: needinfo?(mh+mozilla)
You need to log in before you can comment on or make changes to this bug.