unnecessary <br> at the end of text in table

VERIFIED DUPLICATE of bug 150403

Status

SeaMonkey
Composer
VERIFIED DUPLICATE of bug 150403
16 years ago
4 years ago

People

(Reporter: Arthit Suriyawongkul, Unassigned)

Tracking

({testcase})

Trunk
Sun
Solaris
testcase

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.0rc3) Gecko/20020614
Netscape/7.0b1

Mozilla BuildID:    2002061522
(also found in Netscape 7 PR1, Mozilla 1.0, 1.1a ..Windows & Solaris)


Reproducible: Always
Steps to Reproduce:
1.click table button at toolbar -> to create table
2.click ok -> got 2x2 table
3.fill "1","2","3","4" to each cell of table
4.see html source

Actual Results:  <table cellpadding="2" cellspacing="2" border="1" width="100%">
   <tbody>
     <tr>
       <td valign="top">1<br>
       </td>
       <td valign="top">2<br>
       </td>
     </tr>
     <tr>
       <td valign="top">3<br>
       </td>
       <td valign="top">4<br>
       </td>
     </tr>
   
  </tbody> 
</table>

----

- 1 <br> at the end of text in table
- 1 (new line) after </tr>, before </tobdy>
- 1 (space) after </tbody>, before </table>


Expected Results:  <table cellpadding="2" cellspacing="2" border="1" width="100%">
   <tbody>
     <tr>
       <td valign="top">1</td>
       <td valign="top">2</td>
     </tr>
     <tr>
       <td valign="top">3</td>
       <td valign="top">4</td>
     </tr>
  </tbody> 
</table>

----

- no <br> at the end of text in table
- no (new line) after </tr>, before </tobdy>
- no (space) after </tbody>, before </table>

these unnecessary chars cause:
- hard to read the source, long source
- bigger file size, waste disk space/bandwidth, render relatively slower

Comment 1

16 years ago
Created attachment 89046 [details]
Testcase

Confirming similar in 2002062308 PC Win98 when following the same steps.

<br> at end of text in each dell
<br> after </table>

Other things described by reporter did not occur in this test.

Updated

16 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: testcase

Comment 2

16 years ago
You should always add a <BR> at the end of the text in cells; because very older
browsers that do not support Tables may accidentally render the text of several
cells into a single line. On actual browsers, a <BR> at the end of a cell has no
visible effect.

Nevertheless, I agree that the new line after </tr>, before </tobdy>; and the
space after </tbody>, before </table>, are unnecessary.

Comment 3

16 years ago
*** Bug 160950 has been marked as a duplicate of this bug. ***

Comment 4

16 years ago
So, if comment 2 is a valid argument, does it mean that there's a bug in Gecko?
Dupping to assigned bug.

*** This bug has been marked as a duplicate of 150403 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 6

16 years ago
verified.
Status: RESOLVED → VERIFIED

Comment 7

16 years ago
reassign in case bugs are later reopened
Assignee: syd → composer
Product: Browser → Seamonkey

Comment 8

4 years ago
This isn't really a duplicat of #150403.
And it still persists after 12 years!
See also #280187#c0 for a description of how it mangles layout.
You need to log in before you can comment on or make changes to this bug.