Cannot close Preferences dialog after getting new themes

VERIFIED WORKSFORME

Status

SeaMonkey
Preferences
VERIFIED WORKSFORME
16 years ago
13 years ago

People

(Reporter: julius ross, Assigned: timeless)

Tracking

Trunk
PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.1a) Gecko/20020619
BuildID:    2002061908

After getting a new theme the preferences dialog cannot be closed.

Reproducible: Always
Steps to Reproduce:
1.Open Preferences->Appearance->Themes
2.Click on get new themes
3.Click on deskmod.org


Actual Results:  There is no way to close the window titled "Deskmod Your Souce
for ..."


Expected Results:  Should be able to close it

Comment 1

16 years ago
WorksForMe using FizzillaCFM/2002062203.
(Reporter)

Comment 2

16 years ago
I have just discovered that it depends on your value of
Preferences->Advanced->Scripts and Plugins->(Allow web pages to)Open a link in a
new window

I still think this is a bug:

Reproducible: Always
Steps to Reproduce:
1.Make sure that Preferences->Advanced->Scripts and Plugins->(Allow web pages
to)Open a link in a new window is not checked
2.Restart Mozilla
3.Open Preferences->Appearance->Themes
4.Click on get new themes
5.Click on deskmod.org


Actual Results:  There is no way to close the window titled "Deskmod Your Souce
for ..."
Expected Results:  Should be able to close it

Comment 3

16 years ago
What build are you using now? Using FizzillaCFM/2002081503, I see an option to
"Allow scripts to:" and "Open unrequested windows." in
Preferences/Advanced/Scripts & Plugins. Perhaps it's changed recently. Anyway,
with that unchecked, this still WorksForMe.
(Reporter)

Comment 4

16 years ago
Build 2002081408 for mac osx.  

Greg: is the deskmod.org page meant to appear in the same window as the
preferences or should it open a new window?  In my case it appears in the same
window which is why I cannot close it.

Comment 5

16 years ago
Julius, when I access Mozilla/Preferences/Appearance/Themes and click "Get New
Themes", a new browser window is opened, titled "Download A Mozilla Theme". If I
then click DeskMod, another new browser window is opened, showing the DeskMod site.

Are you saying these pages are opened in your *Preferences* window? Can you
attach a screenshot?
(Assignee)

Comment 6

16 years ago
this is my fault. you'll see a message in the jsconsole which shows the problem.
Assignee: ben → timeless

Comment 7

16 years ago
*** Bug 163711 has been marked as a duplicate of this bug. ***

Comment 8

15 years ago
timeless, does your comment 6 mean you confirm this bug?

julius, can you still reproduce this problem using a current nightly build?
Summary: Cannot close preferences dialog after getting new themes → Cannot close Preferences dialog after getting new themes
(Reporter)

Comment 9

15 years ago
Greg: I cannot reproduce this with a recent nightly (Mach-O 20030213)

Comment 10

15 years ago
Resolving WFM per comment 9.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
v
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.