Add tests for the Picture-in-Picture toggle

RESOLVED FIXED in Firefox 68

Status

()

defect
P1
normal
RESOLVED FIXED
4 months ago
18 days ago

People

(Reporter: mconley, Assigned: mconley)

Tracking

(Blocks 1 bug)

unspecified
mozilla68
Points:
---
Dependency tree / graph
Bug Flags:
qe-verify -

Firefox Tracking Flags

(firefox68 fixed)

Details

Attachments

(2 attachments)

Once bug 1535354 lands, we should get some automated tests in there for it.

Assignee: nobody → mconley
Priority: -- → P1

We needed to handle the case where closePictureInPicture was being called on a window
that had already been closed but not yet GC'd.

Depends on D26807

This still hasn't landed because I'm trying to get the tests to pass reliably in automation:

https://treeherder.mozilla.org/#/jobs?repo=try&revision=f6fdb6086b4854667c2641ed2acd5ac545151c3a

See Also: → 1546455
Pushed by mconley@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/1eae82ecc532
Make Picture-in-Picture window closing more resilient to races. r=Felipe
https://hg.mozilla.org/integration/autoland/rev/3fe91f0bfbff
Add some automated tests for the Picture-in-Picture toggle. r=Felipe
Status: NEW → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla68
Regressions: 1547194
Regressions: 1546887
Depends on: 1549054
Flags: qe-verify-
You need to log in before you can comment on or make changes to this bug.