Closed Bug 1540879 Opened 5 months ago Closed 4 months ago

JavaScript warning: chrome://global/content/bindings/tabbox.xml, line 162: Array.forEach is deprecated; use Array.prototype.forEach instead

Categories

(Toolkit :: XUL Widgets, defect, P5)

defect
Points:
1

Tracking

()

RESOLVED FIXED
mozilla68
Iteration:
68.3 - Apr 15 - 28
Tracking Status
firefox68 --- fixed

People

(Reporter: dholbert, Assigned: dao)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

I noticed the following error debug-spew in my terminal while running a ./mach wpt command[1] (though I imagine the command's not that important and this probably gets logged by lots of stuff that excercises tabbox.xml):

JavaScript warning: chrome://global/content/bindings/tabbox.xml, line 162:
  Array.forEach is deprecated; use Array.prototype.forEach instead

[1] The exact command I used (probably not important) was:

xvfb-run ./mach wpt --verify \
testing/web-platform/tests/css/css-flexbox/quirks-auto-block-size-with-percentage-item.html
Component: General → Tabbed Browser
Priority: -- → P5

Hi, I have the same message:

Gtk-Message: 19:21:23.124: Failed to load module "appmenu-gtk-module"

and

JavaScript warning: chrome://global/content/bindings/tabbox.xml, line 162: Array.forEach is deprecated; use Array.prototype.forEach instead

and

JavaScript warning: chrome://browser/content/browser-ctrlTab.js, line 568: Array.filter is deprecated; use Array.prototype.filter instead

and

JavaScript warning: chrome://browser/content/tabbrowser.js, line 4834: Array.unshift is deprecated; use Array.prototype.unshift instead

and

JavaScript warning: resource:///modules/sessionstore/SessionStore.jsm, line 4040: Array.slice is deprecated; use Array.prototype.slice instead

and

JavaScript warning: chrome://global/content/bindings/tabbox.xml, line 258: Array.indexOf is deprecated; use Array.prototype.indexOf instead

and

JavaScript warning: resource:///modules/AsyncTabSwitcher.jsm, line 422: Array.indexOf is deprecated; use Array.prototype.indexOf instead

and

JavaScript error: resource://gre/modules/ExtensionCommon.jsm, line 2173: Error: listener not re-registered

and

JavaScript error: undefined, line 0: Error: No such PKCS#11 module bry_kms_extension64

Thanks!

Duplicate of this bug: 1542373

This is quite prevalent during testing (>10K), the bug that got duplicated here has a pretty thorough breakdown.

Blocks: logspam
See Also: → 1540444
Component: Tabbed Browser → XUL Widgets
Product: Firefox → Toolkit
Assignee: nobody → dao+bmo
Status: NEW → ASSIGNED

FYI I'm going through the whole Firefox code to replace the use of generics Arrays (bug 1544834), and am skipping tabbox.xml because you already have a patch up here.

If you encounter other occurrences of deprecated Array generics, just leave them alone since they are already part of bug 1544834.

Duplicate of this bug: 1542295
Pushed by gijskruitbosch@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/2a745d4407f4
Stop using deprecated Array generics in tabbox.xml. r=Gijs
Status: ASSIGNED → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla68
Iteration: --- → 68.3 - Apr 15 - 28
Points: --- → 1
You need to log in before you can comment on or make changes to this bug.