"My Sidebar" in Address Book can't show at the first time

VERIFIED FIXED

Status

SeaMonkey
Sidebar
VERIFIED FIXED
16 years ago
13 years ago

People

(Reporter: Cindy Fan, Assigned: Robin Lu)

Tracking

({fixedOEM})

Trunk
x86
All
fixedOEM

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

748 bytes, patch
Stephen P. Morse
: review+
Alec Flett
: superreview+
Details | Diff | Splinter Review
(Reporter)

Description

16 years ago
Steps to Reproduce:
1.Open the browser.
2.Go to Address Book window by clicking "Tools"->"Address Book".
3.Click the little bar in the middle of left pane to minimize the "My sidebar".
4.Press F9 to hide "My sidebar".
5.Press F9 to show "My sidebar".
 
Expected Result:
"My sidebar" is showed correctly or is minimized.

Actual Result:
"My sidebar" is showed but no content at all.

Comment 1

16 years ago
*** Bug 154095 has been marked as a duplicate of this bug. ***

Comment 2

16 years ago
*** Bug 154094 has been marked as a duplicate of this bug. ***

Comment 3

16 years ago
*** Bug 154093 has been marked as a duplicate of this bug. ***

Comment 4

16 years ago
*** Bug 154092 has been marked as a duplicate of this bug. ***

Comment 5

16 years ago
*** Bug 154090 has been marked as a duplicate of this bug. ***

Comment 6

16 years ago
*** Bug 154091 has been marked as a duplicate of this bug. ***

Comment 7

16 years ago
*** Bug 154097 has been marked as a duplicate of this bug. ***

Updated

16 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 8

16 years ago
Reassign to Silvia
Assignee: cindy.fan → silvia.zhao

Updated

16 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 9

16 years ago
Created attachment 90293 [details] [diff] [review]
patch
(Assignee)

Comment 10

16 years ago
reassign to Robin Lu
Assignee: silvia.zhao → robin.lu
Status: ASSIGNED → NEW
(Assignee)

Updated

16 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 11

16 years ago
seek r=

Updated

16 years ago
Keywords: review

Comment 12

16 years ago
Could you please list the test matrix this has been put through?  Have you
tested against old profiles, i.e., profiles created with Netscape 6.0, 6.1, 6.2,
7.0PR1?  Have you toggled the sidebar between collapsed, hidden, visible etc.? 
Has this been tested in the browser, mail, composer, and standalone IM?  Thanks.

Patch looks good (and innocuous).
(Assignee)

Comment 13

16 years ago
Samir Gehani,

Thanks for your comments!

Untill now, the test status is:

Test against old profile
Netscape 6.2.3 profile    Passed
The other old profile     NA      lack of old profiles


Toggle scenario:
1.Toggle between collapsed and visible with mouse
2.Toggle between hidden and visible with F9 or menu
3.Toggle from collapsed to hidden with F9 or menu
4.Toggle from collapsed to hidden then between hidden and visible with F9 or menu
Test in browser with scenario 1 to 4  passed on Redhat Linux 7.2 and Solaris 8
Test in mailnews with scenario 1 to 4 passed on Redhat Linux 7.2 and Solaris 8
Test in addressbook with scenario 1 to 4 passed on Redhat Linux 7.2 and Solaris 8
Test in composer with scenario 1 to 4  passed on Redhat Linux 7.2 and Solaris 8
Test with standalone IM 1 passed, 2 to 4 passed with menu, F9 is captured by IM.
Passed on Solaris 8 (Chinese Simplified)

Since the patch does not change the treatment of profile, can we consider the
test as pass?

Comment 14

16 years ago
Comment on attachment 90293 [details] [diff] [review]
patch

r=morse since patch looks harmless

Comment 15

16 years ago
Comment on attachment 90293 [details] [diff] [review]
patch

r=morse since patch looks harmless
Attachment #90293 - Flags: review+
(Assignee)

Comment 16

16 years ago
seek sr=?
Whiteboard: seek sr=?

Comment 17

16 years ago
robin, make sure you have mailed the people you want to sr= this patch, add
cc-ed reviewers@mozilla.org. bugmail is not going to be sufficient to get their
attention.

Comment 18

16 years ago
Comment on attachment 90293 [details] [diff] [review]
patch

sr=alecf
(I'm one of the few super-reviewers who actually read my bugmail, so you don't
need to e-mail me :))
Attachment #90293 - Flags: superreview+

Comment 19

16 years ago
Comment on attachment 90293 [details] [diff] [review]
patch

a=asa (on behalf of drivers) for checkin to 1.1
Attachment #90293 - Flags: approval+

Comment 20

16 years ago
checked into trunk!
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED

Updated

16 years ago
Whiteboard: seek sr=? → seek sr=? branchOEM

Updated

16 years ago
Whiteboard: seek sr=? branchOEM → seek sr=? branchOEM+

Comment 21

16 years ago
checked in NETSCAPE_7_0_OEM_BRANCH.

Updated

16 years ago
Whiteboard: seek sr=? branchOEM+ → seek sr=? branchOEM+, fixedOEM
(Assignee)

Comment 22

16 years ago
verified at Mozilla 1.1b
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.1b) Gecko/20020722
Status: RESOLVED → VERIFIED

Updated

16 years ago
Keywords: review
Whiteboard: seek sr=? branchOEM+, fixedOEM → fixedOEM

Updated

15 years ago
Keywords: fixedOEM
Whiteboard: fixedOEM
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.