Perma idle-detection-allowed-by-feature-policy-attribute-redirect-on-load.https.sub.html | Attribute allow="idle-detection" in top-level frame allows same-origin relocation. - frame.allow is undefined when Gecko 68 merges to Beta on 2019-05-06

VERIFIED FIXED in Firefox 68

Status

defect
VERIFIED FIXED
3 months ago
2 months ago

People

(Reporter: NarcisB, Assigned: aryx)

Tracking

Version 3
mozilla68
Points:
---

Firefox Tracking Flags

(firefox66 unaffected, firefox67 unaffected, firefox68+ verified)

Details

Attachments

(1 attachment)

Reporter

Description

3 months ago

Central as beta simulation:
https://treeherder.mozilla.org/#/jobs?repo=try&resultStatus=testfailed%2Cbusted%2Cexception%2Cretry%2Cusercancel%2Crunnable&revision=28960fb4fcc50c31342426351f69152ad38972d7

Failure log:
https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=237574691&repo=try&lineNumber=11432

Log snippet:
[task 2019-04-02T12:48:29.617Z] 12:48:29 INFO - TEST-START | /idle-detection/idle-detection-allowed-by-feature-policy-attribute-redirect-on-load.https.sub.html
[task 2019-04-02T12:48:29.620Z] 12:48:29 INFO - Closing window 39
[task 2019-04-02T12:48:29.770Z] 12:48:29 INFO - PID 4474 | ++DOCSHELL 0xdbc46800 == 14 [pid = 4474] [id = {c21bf7d2-4b46-4f4b-ad52-d417b93a84d1}]
[task 2019-04-02T12:48:29.771Z] 12:48:29 INFO - PID 4474 | ++DOMWINDOW == 43 (0xdc057020) [pid = 4474] [serial = 43] [outer = (nil)]
[task 2019-04-02T12:48:29.779Z] 12:48:29 INFO - PID 4474 | ++DOMWINDOW == 44 (0xdbc4c000) [pid = 4474] [serial = 44] [outer = 0xdc057020]
[task 2019-04-02T12:48:29.860Z] 12:48:29 INFO - PID 4474 | ++DOMWINDOW == 45 (0xdbc4e000) [pid = 4474] [serial = 45] [outer = 0xdc057020]
[task 2019-04-02T12:48:30.178Z] 12:48:30 INFO - PID 4474 | ++DOMWINDOW == 46 (0xdbc54c00) [pid = 4474] [serial = 46] [outer = 0xdc057020]
[task 2019-04-02T12:48:30.523Z] 12:48:30 INFO -
[task 2019-04-02T12:48:30.523Z] 12:48:30 INFO - TEST-UNEXPECTED-FAIL | /idle-detection/idle-detection-allowed-by-feature-policy-attribute-redirect-on-load.https.sub.html | Attribute allow="idle-detection" in top-level frame allows same-origin relocation. - frame.allow is undefined
[task 2019-04-02T12:48:30.523Z] 12:48:30 INFO - test_feature_availability@https://web-platform.test:8443/feature-policy/resources/featurepolicy.js:36:5
[task 2019-04-02T12:48:30.524Z] 12:48:30 INFO - @https://web-platform.test:8443/idle-detection/idle-detection-allowed-by-feature-policy-attribute-redirect-on-load.https.sub.html:22:3
[task 2019-04-02T12:48:30.524Z] 12:48:30 INFO - Test.prototype.step@https://web-platform.test:8443/resources/testharness.js:1587:25
[task 2019-04-02T12:48:30.525Z] 12:48:30 INFO - async_test@https://web-platform.test:8443/resources/testharness.js:576:22
[task 2019-04-02T12:48:30.525Z] 12:48:30 INFO - @https://web-platform.test:8443/idle-detection/idle-detection-allowed-by-feature-policy-attribute-redirect-on-load.https.sub.html:21:1
[task 2019-04-02T12:48:30.526Z] 12:48:30 INFO - TEST-INFO | expected TIMEOUT

Reporter

Comment 1

3 months ago

:james , this seems to be caused by https://hg.mozilla.org/mozilla-central/rev/efb5d6396f3c
Could you please take a look?

Flags: needinfo?(james)
Comment hidden (Intermittent Failures Robot)

Comment 4

3 months ago
Pushed by archaeopteryx@coole-files.de:
https://hg.mozilla.org/integration/autoland/rev/3fb311555933
Enable feature policy for idle-detection tests which use it. r=jgraham

Comment 5

3 months ago
bugherder
Status: NEW → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla68
Assignee: nobody → aryx.bugmail
Flags: needinfo?(james)
Comment hidden (Intermittent Failures Robot)
You need to log in before you can comment on or make changes to this bug.