Closed Bug 1541175 Opened 10 months ago Closed 9 months ago

When entering Responsive Design Mode, UI should be fixed at 100% zoom

Categories

(DevTools :: Responsive Design Mode, defect, P1)

defect

Tracking

(firefox68 verified, firefox69 verified)

VERIFIED FIXED
Firefox 68
Tracking Status
firefox68 --- verified
firefox69 --- verified

People

(Reporter: bradwerth, Assigned: bradwerth)

References

(Blocks 1 open bug)

Details

(Whiteboard: [rdm-mvp])

Attachments

(3 files, 3 obsolete files)

Steps to Reproduce:

  1. Open any page.
  2. Set the full zoom level to 150%
  3. Start Responsive Design Mode

Actual Results: the RDM UI will appear magnified to 150%
Expected Results: the RDM UI should appear at 100% zoom

Priority: -- → P2
Assignee: nobody → bwerth
Priority: P2 → P1

Due to review comments, and a desire to more completely fix the problem, this will need to depend on Bug 1541158.

Depends on: 1541158
Whiteboard: [rdm-mvp]
Status: NEW → ASSIGNED

This supports embedded browsers (as used in devtools Responsive Design
Mode) as a source of truth for zoom values. The ZoomManager can now
associate a zoom source for each browser it might later be asked to get
or set zoom values.

Depends on D26394

Depends on D26395

Attachment #9055684 - Attachment description: Bug 1541175 Part 1: Force RDM UI to be at 100% zoom. → Bug 1541175 Part 4: Force RDM UI to be at 100% zoom.

This is becoming a lot more complicated than I expected. The attached patches get us close to desired behavior, but there still are cases where the zoom UI values can be incorrect relative to the actual zoom level of the RDM content.

Attachment #9056287 - Attachment description: Bug 1541175 Part 3: Set and clear ZoomManager zoomSources for RDM panes. → Bug 1541175 Part 3: Set and clear ZoomManager zoom sources for RDM panes.

Depends on D26045

Blocks: 1548435

There is no need to transfer these properties because the swap makes
the outer browser act as if it is remote, and then the message manager
tunnel ensures that the outer browser will get and set the zoom values
from the inner browser.

Attachment #9055684 - Attachment description: Bug 1541175 Part 4: Force RDM UI to be at 100% zoom. → Bug 1541175 Part 2: Force RDM UI to be at 100% zoom.
Attachment #9056722 - Attachment description: Bug 1541175 Part 5: Update test expectations. → Bug 1541175 Part 3: Update test expectations.
Attachment #9056284 - Attachment is obsolete: true
Attachment #9056286 - Attachment is obsolete: true
Attachment #9056287 - Attachment is obsolete: true
Pushed by bwerth@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/b377b5bdd883
Part 1: Prevent fullZoom and textZoom from being remapped on RDM docshell swap. r=ochameau
https://hg.mozilla.org/integration/autoland/rev/2f85ada34acb
Part 2: Force RDM UI to be at 100% zoom. r=pbro,ochameau
https://hg.mozilla.org/integration/autoland/rev/20a54f437d51
Part 3: Update test expectations. r=ochameau
Status: ASSIGNED → RESOLVED
Closed: 9 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 68
Duplicate of this bug: 1548435
Blocks: rdm-zoom

Hi This issue is Verified as fixed in Firefox Nightly 69.0a1 (2019-06-03). I will mark this issue accordingly.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.