[RTL] Show the Picture-In-Picture popup on the left side of the screen by default

VERIFIED FIXED in Firefox 69

Status

()

defect
P2
normal
VERIFIED FIXED
5 months ago
2 months ago

People

(Reporter: itiel_yn8, Assigned: mconley)

Tracking

(Blocks 1 bug, {rtl})

unspecified
mozilla69
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox69 verified)

Details

Attachments

(1 attachment)

RTL users are most likely to browse more websites with RTL content, so having the PIP video show up on the right side of the screen by default will probably interrupt users workflow (by hiding text on the right).
The right solution I think would be to display the PIP by default on the left side of the screen for RTL users.

Priority: -- → P2
See Also: → 1545869
Assignee: nobody → mconley
Duplicate of this bug: 1545869
Pushed by mconley@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/7716b5af6798
In RTL locales, put the Picture-in-Picture to the left side of the window. r=JSON_voorhees
Status: NEW → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla69

Build ID 20190626093633
User Agent Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:69.0) Gecko/20100101 Firefox/69.0

Verified as fixed on the latest Nightly build on Windows 10.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.