3.78% tsvgr_opacity (linux64-shippable) regression on push df0decf794e26365a9a8a366952686fc21593ce8 (Sun Mar 31 2019)

VERIFIED FIXED in Firefox 68

Status

()

defect
P3
normal
VERIFIED FIXED
2 months ago
28 days ago

People

(Reporter: Bebe, Assigned: lsalzman)

Tracking

(Blocks 1 bug, Regression, 4 keywords)

unspecified
mozilla68
x86_64
Unspecified
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr60 unaffected, firefox66 unaffected, firefox67 unaffected, firefox68 fixed)

Details

Attachments

(2 attachments)

Reporter

Description

2 months ago

Talos has detected a Firefox performance regression from push:

https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?changeset=df0decf794e26365a9a8a366952686fc21593ce8

As author of one of the patches included in that push, we need your help to address this regression.

Regressions:

4% tsvgr_opacity linux64-shippable opt e10s stylo 155.25 -> 161.12

You can find links to graphs and comparison views for each of the above tests at: https://treeherder.mozilla.org/perf.html#/alerts?id=20235

On the page above you can see an alert for each affected platform as well as a link to a graph showing the history of scores for this test. There is also a link to a treeherder page showing the Talos jobs in a pushlog format.

To learn more about the regressing test(s), please see: https://wiki.mozilla.org/Performance_sheriffing/Talos/Tests

For information on reproducing and debugging the regression, either on try or locally, see: https://wiki.mozilla.org/Performance_sheriffing/Talos/Running

*** Please let us know your plans within 3 business days, or the offending patch(es) will be backed out! ***

Our wiki page outlines the common responses and expectations: https://wiki.mozilla.org/Performance_sheriffing/Talos/RegressionBugsHandling

Reporter

Updated

2 months ago
Blocks: 1539026, 1534654
Component: General → Graphics
Product: Testing → Core
Regressed by: 1539026
Version: Version 3 → unspecified
Flags: needinfo?(lsalzman)
Assignee

Updated

2 months ago
Assignee: nobody → lsalzman
Status: NEW → ASSIGNED
Flags: needinfo?(lsalzman)
Priority: -- → P3
Hardware: Unspecified → x86_64

Comment 3

a month ago
Pushed by lsalzman@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/68df166b4d9e
optimize SkBlitRow::Color32 for SSE2. r=jrmuizel

Backed out changeset 68df166b4d9e (Bug 1541350) for RGBX corner pixel assertion failures

Push with failures: https://treeherder.mozilla.org/#/jobs?repo=autoland&fromchange=68df166b4d9e53aaa1ff1e39ea6f3e534814f891&tochange=39655232be1dcb58e8ccf82018a762803001ffba&selectedJob=239357954

Backout link: https://hg.mozilla.org/integration/autoland/rev/39655232be1dcb58e8ccf82018a762803001ffba

Failure log: https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=239357954&repo=autoland&lineNumber=5500

[task 2019-04-10T15:38:52.577Z] 15:38:52 INFO - TEST-START | dom/browser-element/mochitest/test_browserElement_inproc_OpenWindowDifferentOrigin.html
[task 2019-04-10T15:38:52.720Z] 15:38:52 INFO - GECKO(2554) | ++DOMWINDOW == 199 (0xd9798c00) [pid = 2554] [serial = 216] [outer = 0xdb305de0]
[task 2019-04-10T15:38:52.817Z] 15:38:52 INFO - GECKO(2554) | JavaScript warning: http://mochi.test:8888/tests/dom/browser-element/mochitest/browserElementTestHelpers.js, line 36: Array.slice is deprecated; use Array.prototype.slice instead
[task 2019-04-10T15:38:52.873Z] 15:38:52 INFO - GECKO(2554) | ++DOCSHELL 0xd9799800 == 31 [pid = 2554] [id = {d5c3677d-31e4-4aa4-8775-25831004b316}]
[task 2019-04-10T15:38:52.874Z] 15:38:52 INFO - GECKO(2554) | ++DOMWINDOW == 200 (0xdc0c8cd0) [pid = 2554] [serial = 217] [outer = (nil)]
[task 2019-04-10T15:38:52.890Z] 15:38:52 INFO - GECKO(2554) | ++DOMWINDOW == 201 (0xd979b000) [pid = 2554] [serial = 218] [outer = 0xdc0c8cd0]
[task 2019-04-10T15:38:53.012Z] 15:38:53 INFO - GECKO(2554) | ++DOMWINDOW == 202 (0xd979c800) [pid = 2554] [serial = 219] [outer = 0xdc0c8cd0]
[task 2019-04-10T15:38:53.074Z] 15:38:53 INFO - GECKO(2554) | ++DOCSHELL 0xd979a400 == 32 [pid = 2554] [id = {dff32a00-4376-4102-a854-1c73a4e97125}]
[task 2019-04-10T15:38:53.075Z] 15:38:53 INFO - GECKO(2554) | ++DOMWINDOW == 203 (0xdc0c8de0) [pid = 2554] [serial = 220] [outer = (nil)]
[task 2019-04-10T15:38:53.092Z] 15:38:53 INFO - GECKO(2554) | ++DOMWINDOW == 204 (0xd979dc00) [pid = 2554] [serial = 221] [outer = 0xdc0c8de0]
[task 2019-04-10T15:38:53.149Z] 15:38:53 INFO - GECKO(2554) | ++DOMWINDOW == 205 (0xd979ec00) [pid = 2554] [serial = 222] [outer = 0xdc0c8de0]
[task 2019-04-10T15:38:53.367Z] 15:38:53 INFO - GECKO(2554) | ++DOMWINDOW == 206 (0xd97a0800) [pid = 2554] [serial = 223] [outer = 0xdc0c8de0]
[task 2019-04-10T15:38:53.553Z] 15:38:53 INFO - GECKO(2554) | [GFX1]: RGBX corner pixel at (783,53) in 1280x1040 surface, bounded by (286,43,994,20) is not opaque: 149,207,255,250
[task 2019-04-10T15:38:53.553Z] 15:38:53 INFO - GECKO(2554) | Assertion failure: [GFX1]: RGBX corner pixel at (783,53) in 1280x1040 surface, bounded by (286,43,994,20) is not opaque: 149,207,255,250, at /builds/worker/workspace/build/src/gfx/2d/Logging.h:747
[task 2019-04-10T15:39:37.929Z] 15:39:37 INFO - GECKO(2554) | #01: mozilla::gfx::Log<1, mozilla::gfx::CriticalLogger>::WriteLog(std::string const&) [gfx/2d/Logging.h:747]
[task 2019-04-10T15:39:37.929Z] 15:39:37 INFO -
[task 2019-04-10T15:39:37.929Z] 15:39:37 INFO - GECKO(2554) | MEMORY STAT | vsize 698MB | residentFast 338MB | heapAllocated 116MB

Flags: needinfo?(lsalzman)
Assignee

Comment 5

a month ago

The issue turns out to be a bit more complicated than initially thought. I am working with Skia upstream to help get this resolved.

Flags: needinfo?(lsalzman)

Comment 7

a month ago
Pushed by lsalzman@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/03c29de4a29d
restore SkBlitRow::Color32 optimizations. r=rhunt

Comment 8

a month ago
bugherder
Status: ASSIGNED → RESOLVED
Last Resolved: a month ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla68
Status: RESOLVED → VERIFIED

For historical reasons, I'm providing the fix's improvement:

== Change summary for alert #20473 (as of Mon, 15 Apr 2019 19:28:00 GMT) ==

Improvements:

3% tsvgr_opacity linux64-shippable opt e10s stylo 144.91 -> 140.27

For up to date results, see: https://treeherder.mozilla.org/perf.html#/alerts?id=20473

You need to log in before you can comment on or make changes to this bug.