Closed Bug 1541381 Opened 6 months ago Closed 5 months ago

[Ubuntu] Firefox doesn’t load http://www.fishgl.com/

Categories

(Core :: Canvas: WebGL, defect, P3, minor)

Desktop
Linux
defect

Tracking

()

RESOLVED DUPLICATE of bug 1399501
Tracking Status
firefox66 --- wontfix
firefox67 --- wontfix
firefox68 --- fix-optional

People

(Reporter: atrif, Unassigned)

References

()

Details

(Keywords: regression)

Affected versions

  • Firefox 67.0b7 (20190331141835)
  • Firefox 65.0 (20190124174741)
  • Firefox 68.0a1 (20190403060632)
  • Firefox 66.0.2 (20190326175229)

Affected platforms

  • Ubuntu 18.04 x64

Steps to reproduce

  1. Open Firefox and go to http://www.fishgl.com/.

Expected result

  • The website is loaded properly.

Actual result

  • Only a static image is presented.

Regression range

  • This is not a recent regression as I can reproduce on 62.0a1 (20180605220158) as well. I will investigate further in case of an old regression.

Additional Notes

  • Using Intel GPU (Intel® HD Graphics 630, Intel HD Graphics 5500) the website is properly loaded on Chrome too, tested on two stations.
  • Using AMD GPU (ATI Radeon 3000) the website is not loaded on Chrome either.
  • An error is thrown in browser console: “TypeError: Argument 2 of WebGLRenderingContext.attachShader is not an object. three.min.js:508:231”.
Has Regression Range: --- → no
Has STR: --- → yes

Hello, here is the regression range:

Last good revision: cda24082bff8864a6e53726feeae33cae9e17309 (2017-04-14)
First bad revision: 9379831bb9c3d9abfea7dbf8dd06dbdab1d81dc4 (2017-04-15)
Pushlog:
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=cda24082bff8864a6e53726feeae33cae9e17309&tochange=9379831bb9c3d9abfea7dbf8dd06dbdab1d81dc4

Has Regression Range: no → yes

I don't know anything about webgl, but it looks like we're intentionally blocking some feature they're trying to use? ni?jgilbert for confirmation.

Autoplay is only allowed when approved by the user, the site is activated by the user, or media is muted. 4 libs.js:3:13504
TypeError: Argument 2 of WebGLRenderingContext.attachShader is not an object.
three.min.js:508:231
    initMaterial http://cdnjs.cloudflare.com/ajax/libs/three.js/r66/three.min.js:508
    B http://cdnjs.cloudflare.com/ajax/libs/three.js/r66/three.min.js:401
    renderBuffer http://cdnjs.cloudflare.com/ajax/libs/three.js/r66/three.min.js:455
    r http://cdnjs.cloudflare.com/ajax/libs/three.js/r66/three.min.js:393
    render http://cdnjs.cloudflare.com/ajax/libs/three.js/r66/three.min.js:468
    handleFishPrepComplete http://fishgl.com/scripts/app.js:5
    e jQuery
    dispatchEvent http://cdnjs.cloudflare.com/ajax/libs/three.js/r66/three.min.js:147
    prepFishAfterLoad http://fishgl.com/scripts/app.js:2
    e jQuery
NotAllowedError: The play method is not allowed by the user agent or the platform in the current context, possibly because the user denied permission. 4
TypeError: window.ieFlyout is undefinedapp.js:4:13366
    onLoadComplete http://fishgl.com/scripts/app.js:4
    jQuery 6
Flags: needinfo?(jgilbert)
Priority: -- → P3
Status: NEW → RESOLVED
Closed: 5 months ago
Flags: needinfo?(jgilbert)
Resolution: --- → DUPLICATE
Duplicate of bug: 1399501
You need to log in before you can comment on or make changes to this bug.