Closed Bug 1541653 Opened 8 months ago Closed 7 months ago

Perma tier2 android dom/browser-element/mochitest/test_browserElement_inproc_Auth.html | Test timed out.

Categories

(Core :: DOM: Core & HTML, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
Tracking Status
firefox-esr60 --- unaffected
firefox66 --- unaffected
firefox67 --- unaffected
firefox68 --- fixed

People

(Reporter: intermittent-bug-filer, Unassigned)

References

(Regression)

Details

(Keywords: intermittent-failure, regression, Whiteboard: [stockwell disable-recommended])

#[markdown(off)]
Filed by: apavel [at] mozilla.com

https://treeherder.mozilla.org/logviewer.html#?job_id=237975092&repo=autoland

https://queue.taskcluster.net/v1/task/FCA5qkMeT2WJY0q9N8scLA/runs/0/artifacts/public/logs/live_backing.log

[task 2019-04-03T22:59:49.184Z] 22:59:49 INFO - 1409 INFO TEST-START | dom/browser-element/mochitest/test_browserElement_inproc_Auth.html
[task 2019-04-03T23:05:29.756Z] 23:05:29 INFO - 1410 INFO TEST-UNEXPECTED-FAIL | dom/browser-element/mochitest/test_browserElement_inproc_Auth.html | Test timed out.
[task 2019-04-03T23:05:29.756Z] 23:05:29 INFO - SimpleTest.ok@SimpleTest/SimpleTest.js:275:18
[task 2019-04-03T23:05:29.756Z] 23:05:29 INFO - reportError@SimpleTest/TestRunner.js:121:22
[task 2019-04-03T23:05:29.757Z] 23:05:29 INFO - TestRunner._checkForHangs@SimpleTest/TestRunner.js:142:7
[task 2019-04-03T23:05:29.757Z] 23:05:29 INFO - 1411 INFO TEST-OK | dom/browser-element/mochitest/test_browserElement_inproc_Auth.html | took 328360ms
[task 2019-04-03T23:05:29.757Z] 23:05:29 INFO - 1412 INFO TEST-START | dom/browser-element/mochitest/test_browserElement_inproc_BrowserWindowNamespace.html
[task 2019-04-03T23:11:20.663Z] 23:11:20 INFO - 1413 INFO TEST-UNEXPECTED-FAIL | dom/browser-element/mochitest/test_browserElement_inproc_BrowserWindowNamespace.html | Test timed out.
[task 2019-04-03T23:11:20.663Z] 23:11:20 INFO - SimpleTest.ok@SimpleTest/SimpleTest.js:275:18
[task 2019-04-03T23:11:20.664Z] 23:11:20 INFO - reportError@SimpleTest/TestRunner.js:121:22
[task 2019-04-03T23:11:20.664Z] 23:11:20 INFO - TestRunner._checkForHangs@SimpleTest/TestRunner.js:142:7
[task 2019-04-03T23:11:20.664Z] 23:11:20 INFO - 1414 INFO TEST-OK | dom/browser-element/mochitest/test_browserElement_inproc_BrowserWindowNamespace.html | took 330100ms
[task 2019-04-03T23:11:20.665Z] 23:11:20 INFO - 1415 INFO TEST-START | dom/browser-element/mochitest/test_browserElement_inproc_BrowserWindowResize.html
[task 2019-04-03T23:11:20.665Z] 23:11:20 INFO - 1416 INFO TEST-OK | dom/browser-element/mochitest/test_browserElement_inproc_BrowserWindowResize.html | took 140ms
[task 2019-04-03T23:11:20.665Z] 23:11:20 INFO - 1417 INFO TEST-START | dom/browser-element/mochitest/test_browserElement_inproc_Close.html
[task 2019-04-03T23:17:52.800Z] 23:17:52 INFO - wait for org.mozilla.geckoview.test complete; top activity=org.mozilla.geckoview.test
[task 2019-04-03T23:17:52.907Z] 23:17:52 INFO - org.mozilla.geckoview.test unexpectedly found running. Killing...
[task 2019-04-03T23:17:52.909Z] 23:17:52 INFO - TEST-INFO | started process screentopng
[task 2019-04-03T23:17:53.209Z] 23:17:53 INFO - TEST-INFO | screentopng: exit 0
[task 2019-04-03T23:18:07.567Z] 23:18:07 WARNING - TEST-UNEXPECTED-FAIL | dom/browser-element/mochitest/test_browserElement_inproc_Close.html | application timed out after 370 seconds with no output
[task 2019-04-03T23:18:07.567Z] 23:18:07 INFO - remoteautomation.py | Application ran for: 0:18:31.243441
[task 2019-04-03T23:18:08.000Z] 23:18:08 INFO - mozcrash Downloading symbols from: https://queue.taskcluster.net/v1/task/SsLNVtzMStWx_TCaCMvZ1Q/artifacts/public/build/target.crashreporter-symbols.zip
[task 2019-04-03T23:18:11.076Z] 23:18:11 INFO - mozcrash Copy/paste: /builds/worker/workspace/build/linux64-minidump_stackwalk /tmp/tmpbC6Ttj/480f9c52-01ce-05b5-8823-cd5768aa5a1a.dmp /tmp/tmp7m1YHF
[task 2019-04-03T23:18:18.593Z] 23:18:18 INFO - mozcrash Saved minidump as /builds/worker/workspace/build/blobber_upload_dir/480f9c52-01ce-05b5-8823-cd5768aa5a1a.dmp
[task 2019-04-03T23:18:18.593Z] 23:18:18 INFO - mozcrash Saved app info as /builds/worker/workspace/build/blobber_upload_dir/480f9c52-01ce-05b5-8823-cd5768aa5a1a.extra
[task 2019-04-03T23:18:18.595Z] 23:18:18 WARNING - PROCESS-CRASH | dom/browser-element/mochitest/test_browserElement_inproc_Close.html | application crashed [@ libc.so + 0x8c66a]
[task 2019-04-03T23:18:18.595Z] 23:18:18 INFO - Crash dump filename: /tmp/tmpbC6Ttj/480f9c52-01ce-05b5-8823-cd5768aa5a1a.dmp
[task 2019-04-03T23:18:18.595Z] 23:18:18 INFO - Operating system: Android
[task 2019-04-03T23:18:18.595Z] 23:18:18 INFO - 0.0.0 Linux 3.10.0+ #1 PREEMPT Thu Jan 5 00:46:30 UTC 2017 x86_64
[task 2019-04-03T23:18:18.595Z] 23:18:18 INFO - CPU: amd64
[task 2019-04-03T23:18:18.595Z] 23:18:18 INFO - family 6 model 2 stepping 3
[task 2019-04-03T23:18:18.595Z] 23:18:18 INFO - 1 CPU
[task 2019-04-03T23:18:18.595Z] 23:18:18 INFO - GPU: UNKNOWN
[task 2019-04-03T23:18:18.595Z] 23:18:18 INFO - Crash reason: SIGABRT
[task 2019-04-03T23:18:18.595Z] 23:18:18 INFO - Crash address: 0x1990
[task 2019-04-03T23:18:18.595Z] 23:18:18 INFO - Process uptime: not available
[task 2019-04-03T23:18:18.596Z] 23:18:18 INFO - Thread 0 (crashed)
[task 2019-04-03T23:18:18.596Z] 23:18:18 INFO - 0 libc.so + 0x8c66a
[task 2019-04-03T23:18:18.596Z] 23:18:18 INFO - rax = 0xfffffffffffffffc rdx = 0x0000000000000010
[task 2019-04-03T23:18:18.596Z] 23:18:18 INFO - rcx = 0xffffffffffffffff rbx = 0x00000000ffffffff
[task 2019-04-03T23:18:18.596Z] 23:18:18 INFO - rsi = 0x00007fffd8179780 rdi = 0x000000000000001c
[task 2019-04-03T23:18:18.596Z] 23:18:18 INFO - rbp = 0x00000000ffffffff rsp = 0x00007fffd8179708
[task 2019-04-03T23:18:18.596Z] 23:18:18 INFO - r8 = 0x0000000000000000 r9 = 0x0000000000000008
[task 2019-04-03T23:18:18.596Z] 23:18:18 INFO - r10 = 0x00000000ffffffff r11 = 0x0000000000000246
[task 2019-04-03T23:18:18.596Z] 23:18:18 INFO - r12 = 0x00000000ffffffff r13 = 0x00007cc1dd529f40
[task 2019-04-03T23:18:18.596Z] 23:18:18 INFO - r14 = 0x0000000000000000 r15 = 0x0000000000000000
[task 2019-04-03T23:18:18.596Z] 23:18:18 INFO - rip = 0x00007cc1e13d766a
[task 2019-04-03T23:18:18.596Z] 23:18:18 INFO - Found by: given as instruction pointer in context
[task 2019-04-03T23:18:18.596Z] 23:18:18 INFO - 1 libc.so + 0x2a0e6
[task 2019-04-03T23:18:18.596Z] 23:18:18 INFO - rsp = 0x00007fffd8179710 rip = 0x00007cc1e13750e6
[task 2019-04-03T23:18:18.596Z] 23:18:18 INFO - Found by: stack scanning
[task 2019-04-03T23:18:18.596Z] 23:18:18 INFO - 2 libutils.so + 0x184e7
[task 2019-04-03T23:18:18.596Z] 23:18:18 INFO - rsp = 0x00007fffd8179730 rip = 0x00007cc1ddd334e7
[task 2019-04-03T23:18:18.596Z] 23:18:18 INFO - Found by: stack scanning
[task 2019-04-03T23:18:18.596Z] 23:18:18 INFO - 3 libart.so + 0x14cd91
[task 2019-04-03T23:18:18.596Z] 23:18:18 INFO - rsp = 0x00007fffd8179740 rip = 0x00007cc1dce58d91
[task 2019-04-03T23:18:18.596Z] 23:18:18 INFO - Found by: stack scanning
[task 2019-04-03T23:18:18.597Z] 23:18:18 INFO - 4 system@framework@boot-framework.art + 0x3d5350
[task 2019-04-03T23:18:18.597Z] 23:18:18 INFO - rsp = 0x00007fffd8179758 rip = 0x0000000071675350
[task 2019-04-03T23:18:18.597Z] 23:18:18 INFO - Found by: stack scanning
[task 2019-04-03T23:18:18.597Z] 23:18:18 INFO - 5 boot-framework.oat + 0x1000
[task 2019-04-03T23:18:18.597Z] 23:18:18 INFO - rsp = 0x00007fffd8179768 rip = 0x0000000072f54000
[task 2019-04-03T23:18:18.597Z] 23:18:18 INFO - Found by: stack scanning
[task 2019-04-03T23:18:18.597Z] 23:18:18 INFO - 6 dalvik-main space (deleted) + 0x32c60
[task 2019-04-03T23:18:18.600Z] 23:18:18 INFO - rsp = 0x00007fffd8179780 rip = 0x0000000012c32c60
[task 2019-04-03T23:18:18.600Z] 23:18:18 INFO - Found by: stack scanning
[task 2019-04-03T23:18:18.600Z] 23:18:18 INFO - 7 libart.so + 0x14cd91
[task 2019-04-03T23:18:18.600Z] 23:18:18 INFO - rsp = 0x00007fffd81797e0 rip = 0x00007cc1dce58d91
[task 2019-04-03T23:18:18.600Z] 23:18:18 INFO - Found by: stack scanning
[task 2019-04-03T23:18:18.600Z] 23:18:18 INFO - 8 libart.so + 0x39c37f
[task 2019-04-03T23:18:18.600Z] 23:18:18 INFO - rsp = 0x00007fffd8179820 rip = 0x00007cc1dd0a837f
[task 2019-04-03T23:18:18.600Z] 23:18:18 INFO - Found by: stack scanning
[task 2019-04-03T23:18:18.600Z] 23:18:18 INFO - 9 libart.so + 0x6e3c40
[task 2019-04-03T23:18:18.600Z] 23:18:18 INFO - rsp = 0x00007fffd8179828 rip = 0x00007cc1dd3efc40
[task 2019-04-03T23:18:18.600Z] 23:18:18 INFO - Found by: stack scanning
[task 2019-04-03T23:18:18.600Z] 23:18:18 INFO - 10 libutils.so + 0x1837b
[task 2019-04-03T23:18:18.600Z] 23:18:18 INFO - rsp = 0x00007fffd8179880 rip = 0x00007cc1ddd3337b
[task 2019-04-03T23:18:18.600Z] 23:18:18 INFO - Found by: stack scanning
[task 2019-04-03T23:18:18.600Z] 23:18:18 INFO - 11 system@framework@boot-framework.art + 0x3f5b10
[task 2019-04-03T23:18:18.600Z] 23:18:18 INFO - rsp = 0x00007fffd81798a8 rip = 0x0000000071695b10
[task 2019-04-03T23:18:18.600Z] 23:18:18 INFO - Found by: stack scanning
[task 2019-04-03T23:18:18.600Z] 23:18:18 INFO - 12 dalvik-main space (deleted) + 0x95d8
[task 2019-04-03T23:18:18.600Z] 23:18:18 INFO - rsp = 0x00007fffd81798b0 rip = 0x0000000012c095d8
[task 2019-04-03T23:18:18.600Z] 23:18:18 INFO - Found by: stack scanning
[task 2019-04-03T23:18:18.600Z] 23:18:18 INFO - 13 libandroid_runtime.so + 0xff856
[task 2019-04-03T23:18:18.600Z] 23:18:18 INFO - rsp = 0x00007fffd81798c0 rip = 0x00007cc1dd9a7856
[task 2019-04-03T23:18:18.600Z] 23:18:18 INFO - Found by: stack scanning
[task 2019-04-03T23:18:18.600Z] 23:18:18 INFO - 14 system@framework@boot-framework.art + 0x3f5b10
[task 2019-04-03T23:18:18.600Z] 23:18:18 INFO - rsp = 0x00007fffd81798c8 rip = 0x0000000071695b10
[task 2019-04-03T23:18:18.600Z] 23:18:18 INFO - Found by: stack scanning
[task 2019-04-03T23:18:18.600Z] 23:18:18 INFO - 15 boot-framework.oat + 0x1e17220
[task 2019-04-03T23:18:18.600Z] 23:18:18 INFO - rsp = 0x00007fffd81798e0 rip = 0x0000000074d6a220
[task 2019-04-03T23:18:18.600Z] 23:18:18 INFO - Found by: stack scanning

Summary: Intermittent dom/browser-element/mochitest/test_browserElement_inproc_Auth.html | Test timed out. → Perma tier2 android dom/browser-element/mochitest/test_browserElement_inproc_Auth.html | Test timed out.

Backfill didn't work because the jobs got changed from M-e10s(1) to M(1), see bug 1541957

Depends on: 1541957
Flags: needinfo?(aryx.bugmail)
Regressed by: 1532747

Andrew can you take a look at this?

There are 185 total failures in the last 7 days on android-em-7-0-x86_64 opt

Recent failure log: https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=238496394&repo=mozilla-inbound&lineNumber=3941

[task 2019-04-05T21:10:17.468Z] 21:10:17 INFO - 1409 INFO TEST-START | dom/browser-element/mochitest/test_browserElement_inproc_Auth.html
[task 2019-04-05T21:15:47.603Z] 21:15:47 INFO - 1410 INFO TEST-UNEXPECTED-FAIL | dom/browser-element/mochitest/test_browserElement_inproc_Auth.html | Test timed out.
[task 2019-04-05T21:15:47.603Z] 21:15:47 INFO - SimpleTest.ok@SimpleTest/SimpleTest.js:275:18
[task 2019-04-05T21:15:47.603Z] 21:15:47 INFO - reportError@SimpleTest/TestRunner.js:121:22
[task 2019-04-05T21:15:47.603Z] 21:15:47 INFO - TestRunner._checkForHangs@SimpleTest/TestRunner.js:142:7
[task 2019-04-05T21:15:47.603Z] 21:15:47 INFO - 1411 INFO TEST-OK | dom/browser-element/mochitest/test_browserElement_inproc_Auth.html | took 328050ms
[task 2019-04-05T21:15:47.603Z] 21:15:47 INFO - 1412 INFO TEST-START | dom/browser-element/mochitest/test_browserElement_inproc_BrowserWindowNamespace.html
[task 2019-04-05T21:21:17.706Z] 21:21:17 INFO - 1413 INFO TEST-UNEXPECTED-FAIL | dom/browser-element/mochitest/test_browserElement_inproc_BrowserWindowNamespace.html | Test timed out.
[task 2019-04-05T21:21:17.706Z] 21:21:17 INFO - SimpleTest.ok@SimpleTest/SimpleTest.js:275:18
[task 2019-04-05T21:21:17.706Z] 21:21:17 INFO - reportError@SimpleTest/TestRunner.js:121:22
[task 2019-04-05T21:21:17.706Z] 21:21:17 INFO - TestRunner._checkForHangs@SimpleTest/TestRunner.js:142:7
[task 2019-04-05T21:21:17.706Z] 21:21:17 INFO - 1414 INFO TEST-OK | dom/browser-element/mochitest/test_browserElement_inproc_BrowserWindowNamespace.html | took 330060ms
[task 2019-04-05T21:21:17.706Z] 21:21:17 INFO - 1415 INFO TEST-START | dom/browser-element/mochitest/test_browserElement_inproc_BrowserWindowResize.html
[task 2019-04-05T21:21:17.707Z] 21:21:17 INFO - 1416 INFO TEST-OK | dom/browser-element/mochitest/test_browserElement_inproc_BrowserWindowResize.html | took 140ms
[task 2019-04-05T21:21:17.707Z] 21:21:17 INFO - 1417 INFO TEST-START | dom/browser-element/mochitest/test_browserElement_inproc_Close.html
[task 2019-04-05T21:27:49.784Z] 21:27:49 INFO - wait for org.mozilla.geckoview.test complete; top activity=org.mozilla.geckoview.test
[task 2019-04-05T21:27:49.891Z] 21:27:49 INFO - org.mozilla.geckoview.test unexpectedly found running. Killing...
[task 2019-04-05T21:27:49.891Z] 21:27:49 INFO - TEST-INFO | started process screentopng
[task 2019-04-05T21:27:50.204Z] 21:27:50 INFO - TEST-INFO | screentopng: exit 0
[task 2019-04-05T21:28:04.590Z] 21:28:04 WARNING - TEST-UNEXPECTED-FAIL | dom/browser-element/mochitest/test_browserElement_inproc_Close.html | application timed out after 370 seconds with no output
[task 2019-04-05T21:28:04.590Z] 21:28:04 INFO - remoteautomation.py | Application ran for: 0:18:01.416367
[task 2019-04-05T21:28:05.271Z] 21:28:05 INFO - mozcrash Downloading symbols from: https://queue.taskcluster.net/v1/task/GQTcCBajRzyliGzhe9BuOw/artifacts/public/build/target.crashreporter-symbols.zip
[task 2019-04-05T21:28:10.346Z] 21:28:10 INFO - mozcrash Copy/paste: /builds/worker/workspace/build/linux64-minidump_stackwalk /tmp/tmpp1dbBi/470f5702-f977-0418-5f89-a54590b8b203.dmp /tmp/tmpT9hPlQ
[task 2019-04-05T21:28:16.511Z] 21:28:16 INFO - mozcrash Saved minidump as /builds/worker/workspace/build/blobber_upload_dir/470f5702-f977-0418-5f89-a54590b8b203.dmp
[task 2019-04-05T21:28:16.511Z] 21:28:16 INFO - mozcrash Saved app info as /builds/worker/workspace/build/blobber_upload_dir/470f5702-f977-0418-5f89-a54590b8b203.extra
[task 2019-04-05T21:28:16.514Z] 21:28:16 WARNING - PROCESS-CRASH | dom/browser-element/mochitest/test_browserElement_inproc_Close.html | application crashed [@ libc.so + 0x8c66a]
[task 2019-04-05T21:28:16.519Z] 21:28:16 INFO - Crash dump filename: /tmp/tmpp1dbBi/470f5702-f977-0418-5f89-a54590b8b203.dmp
[task 2019-04-05T21:28:16.519Z] 21:28:16 INFO - Operating system: Android
[task 2019-04-05T21:28:16.519Z] 21:28:16 INFO - 0.0.0 Linux 3.10.0+ #1 PREEMPT Thu Jan 5 00:46:30 UTC 2017 x86_64
[task 2019-04-05T21:28:16.519Z] 21:28:16 INFO - CPU: amd64
[task 2019-04-05T21:28:16.519Z] 21:28:16 INFO - family 6 model 2 stepping 3
[task 2019-04-05T21:28:16.519Z] 21:28:16 INFO - 1 CPU
[task 2019-04-05T21:28:16.519Z] 21:28:16 INFO - GPU: UNKNOWN
[task 2019-04-05T21:28:16.519Z] 21:28:16 INFO - Crash reason: SIGABRT
[task 2019-04-05T21:28:16.519Z] 21:28:16 INFO - Crash address: 0x1903
[task 2019-04-05T21:28:16.519Z] 21:28:16 INFO - Process uptime: not available
[task 2019-04-05T21:28:16.519Z] 21:28:16 INFO - Thread 0 (crashed)
[task 2019-04-05T21:28:16.519Z] 21:28:16 INFO - 0 libc.so + 0x8c66a
[task 2019-04-05T21:28:16.519Z] 21:28:16 INFO - rax = 0xfffffffffffffffc rdx = 0x0000000000000010
[task 2019-04-05T21:28:16.519Z] 21:28:16 INFO - rcx = 0xffffffffffffffff rbx = 0x00000000ffffffff
[task 2019-04-05T21:28:16.519Z] 21:28:16 INFO - rsi = 0x00007fff8394ca00 rdi = 0x000000000000001c
[task 2019-04-05T21:28:16.519Z] 21:28:16 INFO - rbp = 0x00000000ffffffff rsp = 0x00007fff8394c988
[task 2019-04-05T21:28:16.519Z] 21:28:16 INFO - r8 = 0x0000000000000000 r9 = 0x0000000000000008
[task 2019-04-05T21:28:16.519Z] 21:28:16 INFO - r10 = 0x00000000ffffffff r11 = 0x0000000000000246
[task 2019-04-05T21:28:16.519Z] 21:28:16 INFO - r12 = 0x00000000ffffffff r13 = 0x00007aa7c1b29f40
[task 2019-04-05T21:28:16.519Z] 21:28:16 INFO - r14 = 0x0000000000000000 r15 = 0x0000000000000000
[task 2019-04-05T21:28:16.519Z] 21:28:16 INFO - rip = 0x00007aa7c390d66a
[task 2019-04-05T21:28:16.519Z] 21:28:16 INFO - Found by: given as instruction pointer in context
[task 2019-04-05T21:28:16.519Z] 21:28:16 INFO - 1 libc.so + 0x2a0e6
[task 2019-04-05T21:28:16.519Z] 21:28:16 INFO - rsp = 0x00007fff8394c990 rip = 0x00007aa7c38ab0e6
[task 2019-04-05T21:28:16.519Z] 21:28:16 INFO - Found by: stack scanning
[task 2019-04-05T21:28:16.519Z] 21:28:16 INFO - 2 libutils.so + 0x184e7
[task 2019-04-05T21:28:16.519Z] 21:28:16 INFO - rsp = 0x00007fff8394c9b0 rip = 0x00007aa7c5b814e7
[task 2019-04-05T21:28:16.519Z] 21:28:16 INFO - Found by: stack scanning
[task 2019-04-05T21:28:16.519Z] 21:28:16 INFO - 3 libart.so + 0x14cd91
[task 2019-04-05T21:28:16.519Z] 21:28:16 INFO - rsp = 0x00007fff8394c9c0 rip = 0x00007aa7c1458d91
[task 2019-04-05T21:28:16.519Z] 21:28:16 INFO - Found by: stack scanning
[task 2019-04-05T21:28:16.519Z] 21:28:16 INFO - 4 system@framework@boot-framework.art + 0x3d5350
[task 2019-04-05T21:28:16.519Z] 21:28:16 INFO - rsp = 0x00007fff8394c9d8 rip = 0x0000000071675350
[task 2019-04-05T21:28:16.519Z] 21:28:16 INFO - Found by: stack scanning
[task 2019-04-05T21:28:16.519Z] 21:28:16 INFO - 5 boot-framework.oat + 0x1000
[task 2019-04-05T21:28:16.519Z] 21:28:16 INFO - rsp = 0x00007fff8394c9e8 rip = 0x0000000072f54000
[task 2019-04-05T21:28:16.519Z] 21:28:16 INFO - Found by: stack scanning

Flags: needinfo?(ahal)
Whiteboard: [stockwell disable-recommended] → [stockwell needswork:owner]

This is fixed by bug 1541957.

Status: NEW → RESOLVED
Closed: 7 months ago
Flags: needinfo?(ahal)
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.