[wpt-sync] Sync PR 16158 - [LayoutNG] Fix nested legacy oof descendants

RESOLVED FIXED in Firefox 68

Status

()

defect
P4
normal
RESOLVED FIXED
4 months ago
2 months ago

People

(Reporter: wptsync, Unassigned)

Tracking

unspecified
mozilla68
Points:
---

Firefox Tracking Flags

(firefox68 fixed)

Details

(Whiteboard: [wptsync downstream], )

Sync web-platform-tests PR 16158 into mozilla-central (this bug is closed when the sync is complete).

PR: https://github.com/web-platform-tests/wpt/pull/16158
Details from upstream follow.

Aleks Totic <atotic@chromium.org> wrote:

[LayoutNG] Fix nested legacy oof descendants

Another fix for "Legacy OOF descendant did not get laid out"

The cause here was:

  • if #container had a legacy descendant, and
  • legacy descendant had an oof descendant whose containing block was
    #container, that oof descendant would get added to #container's list
    of legacy oof, but would never get laid out.

This bug was hidden, because it would not happen if layout happened
twice, which we often do.

Seen in the wild at https://www.humblebundle.com/ when scrolling down.

Bug: 946986
Change-Id: I183f3d5dfe79b49c5c6aadad0ee2cfcb8bb6849f
Reviewed-on: https://chromium-review.googlesource.com/c/chromium/src/+/1546713
Commit-Queue: Aleks Totic \<atotic@chromium.org>
Reviewed-by: Ian Kilpatrick \<ikilpatrick@chromium.org>
Auto-Submit: Aleks Totic \<atotic@chromium.org>
Cr-Commit-Position: refs/heads/master@{#646077}

Whiteboard: [wptsync downstream] → [wptsync downstream error]
Component: web-platform-tests → CSS Parsing and Computation
Product: Testing → Core
Whiteboard: [wptsync downstream error] → [wptsync downstream]
Failed to get results from try push
Whiteboard: [wptsync downstream] → [wptsync downstream error]
Pushed by james@hoppipolla.co.uk:
https://hg.mozilla.org/integration/mozilla-inbound/rev/26073cb99912
[wpt PR 16158] - [LayoutNG] Fix nested legacy oof descendants, a=testonly
Status: NEW → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla68
Whiteboard: [wptsync downstream error] → [wptsync downstream]
Whiteboard: [wptsync downstream] → [wptsync downstream error]
Whiteboard: [wptsync downstream error] → [wptsync downstream]
Whiteboard: [wptsync downstream] → [wptsync downstream error]
Whiteboard: [wptsync downstream error] → [wptsync downstream]
Whiteboard: [wptsync downstream] → [wptsync downstream error]
Whiteboard: [wptsync downstream error] → [wptsync downstream]
You need to log in before you can comment on or make changes to this bug.