Closed Bug 1541670 Opened 6 months ago Closed 5 months ago

[wpt-sync] Sync PR 16148 - Send `Sec-Fetch-User` only for user-activated, navigational requests.

Categories

(Core :: DOM: Core & HTML, defect, P4)

defect

Tracking

()

RESOLVED FIXED
mozilla68
Tracking Status
firefox68 --- fixed

People

(Reporter: wptsync, Unassigned)

References

()

Details

(Whiteboard: [wptsync downstream])

Sync web-platform-tests PR 16148 into mozilla-central (this bug is closed when the sync is complete).

PR: https://github.com/web-platform-tests/wpt/pull/16148
Details from upstream follow.

Mike West <mkwst@chromium.org> wrote:

Send Sec-Fetch-User only for user-activated, navigational requests.

As per the conversation in mikewest/sec-metadata#23 and
mikewest/sec-metadata#19, this patch drops the Sec-Fetch-User header
for non-navigational requests, and for navigational requests that are
not user-activated.

Bug: 947444
Change-Id: Ica4846bda6ccf4e8bce1323803954f4fef9c18a3
Reviewed-on: https://chromium-review.googlesource.com/c/chromium/src/+/1545871
Reviewed-by: Alex Moshchuk \<alexmos@chromium.org>
Commit-Queue: Mike West \<mkwst@chromium.org>
Cr-Commit-Position: refs/heads/master@{#646086}

Whiteboard: [wptsync downstream] → [wptsync downstream error]
PR 16148 applied with additional changes from upstream: 4464a966f705350905a434690a2c98a3b4a2b0cb, 22be9a97638436380f88d871ecefac3f1aebfe53, 696d3a7aebc3c610eeddee94fb490aa6662c7e79, c3e58eeeef43bd5a9dd905f1942e79b394d61924
Component: web-platform-tests → DOM: Core & HTML
Product: Testing → Core
Whiteboard: [wptsync downstream error] → [wptsync downstream]
Failed to get results from try push
Whiteboard: [wptsync downstream] → [wptsync downstream error]
Pushed by james@hoppipolla.co.uk:
https://hg.mozilla.org/integration/mozilla-inbound/rev/595f9f3aa36e
[wpt PR 16148] - Send `Sec-Fetch-User` only for user-activated, navigational requests., a=testonly
Status: NEW → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla68
Whiteboard: [wptsync downstream error] → [wptsync downstream]
You need to log in before you can comment on or make changes to this bug.