Crash in [@ mozilla::dom::`anonymous namespace'::Snapshot::RecvCheckpoint]

RESOLVED FIXED in Firefox 68

Status

()

defect
P1
critical
RESOLVED FIXED
5 months ago
2 months ago

People

(Reporter: janv, Assigned: janv)

Tracking

(Blocks 1 bug, Regression, {crash, regression})

Trunk
mozilla68
Unspecified
Windows 10
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr52 unaffected, firefox-esr60 unaffected, firefox66 unaffected, firefox67 unaffected, firefox68 fixed, firefox69 fixed)

Details

(crash signature)

This bug is for crash report bp-7b421c6f-7831-49ce-a56c-dceaf0190404.

Top 10 frames of crashing thread:

0 xul.dll class mozilla::ipc::IPCResult mozilla::dom::`anonymous namespace'::Snapshot::RecvCheckpoint dom/localstorage/ActorsParent.cpp:5358
1 xul.dll mozilla::dom::PBackgroundLSSnapshotParent::OnMessageReceived ipc/ipdl/PBackgroundLSSnapshotParent.cpp:142
2 xul.dll void mozilla::ipc::MessageChannel::DispatchMessage ipc/glue/MessageChannel.cpp:2078
3 xul.dll nsresult mozilla::ipc::MessageChannel::MessageTask::Run ipc/glue/MessageChannel.cpp:1968
4 xul.dll nsThread::ProcessNextEvent xpcom/threads/nsThread.cpp:1180
5 xul.dll NS_ProcessNextEvent xpcom/threads/nsThreadUtils.cpp:482
6 xul.dll mozilla::ipc::MessagePumpForNonMainThreads::Run ipc/glue/MessagePump.cpp:333
7 xul.dll MessageLoop::RunHandler ipc/chromium/src/base/message_loop.cc:308
8 xul.dll static void nsThread::ThreadFunc xpcom/threads/nsThread.cpp:454
9 nss3.dll static void _PR_NativeRunThread nsprpub/pr/src/threads/combined/pruthr.c:397

Blocks: 1540402

This is probably fixed by patch in bug 1542104.

Priority: -- → P1
Assignee: nobody → jvarga
Status: NEW → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla68

this crash signature isn't looking fixed yet.

Status: RESOLVED → REOPENED
Flags: needinfo?(jvarga)
Keywords: regression
Resolution: FIXED → ---
Duplicate of this bug: 1541895
Crash Signature: [@ mozilla::dom::`anonymous namespace'::Snapshot::RecvCheckpoint] → [@ mozilla::dom::`anonymous namespace'::Snapshot::RecvCheckpoint] [@ mozilla::dom::(anonymous namespace)::Snapshot::RecvCheckpoint]
See Also: → 1540401

It seems we will have to convert the assertion back to MOZ_ASSERT.

Status: REOPENED → RESOLVED
Closed: 4 months ago3 months ago
Resolution: --- → FIXED
Flags: needinfo?(jvarga)
Regressed by: 1540401
You need to log in before you can comment on or make changes to this bug.