Closed Bug 1541969 Opened 8 months ago Closed 7 months ago

Intermittent [TV] browser/components/newtab/test/browser/browser_asrouter_cfr.js | Registered pattern matched the current location - 0 == 1 - JS frame :: chrome://mochitests/content/browser/browser/components/newtab/test/browser/browser_asrouter_cfr

Categories

(Firefox :: New Tab Page, defect, P5)

defect

Tracking

()

RESOLVED FIXED
Firefox 68
Tracking Status
firefox-esr60 --- unaffected
firefox67 --- unaffected
firefox68 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: andreio)

Details

(Keywords: intermittent-failure, regression, Whiteboard: [retriggered][stockwell needswork:owner])

Attachments

(1 file)

#[markdown(off)]
Filed by: nbeleuzu [at] mozilla.com

https://treeherder.mozilla.org/logviewer.html#?job_id=238180089&repo=autoland

https://queue.taskcluster.net/v1/task/WLyVG6LqTcmpFYDMxkYaaQ/runs/0/artifacts/public/logs/live_backing.log

[task 2019-04-04T15:39:55.146Z] 15:39:55 INFO - TEST-PASS | browser/components/newtab/test/browser/browser_asrouter_cfr.js | Count navigation to example.com - 1 == 1 -
[task 2019-04-04T15:39:55.147Z] 15:39:55 INFO - TEST-PASS | browser/components/newtab/test/browser/browser_asrouter_cfr.js | It should ignore same page navigation - 1 == 1 -
[task 2019-04-04T15:39:55.149Z] 15:39:55 INFO - TEST-PASS | browser/components/newtab/test/browser/browser_asrouter_cfr.js | We moved to a new document - 2 == 2 -
[task 2019-04-04T15:39:55.150Z] 15:39:55 INFO - Leaving test bound test_onLocationChange_cb
[task 2019-04-04T15:39:55.152Z] 15:39:55 INFO - Entering test bound test_matchPattern
[task 2019-04-04T15:39:55.154Z] 15:39:55 INFO - Buffered messages finished
[task 2019-04-04T15:39:55.155Z] 15:39:55 INFO - TEST-UNEXPECTED-FAIL | browser/components/newtab/test/browser/browser_asrouter_cfr.js | Registered pattern matched the current location - 0 == 1 - JS frame :: chrome://mochitests/content/browser/browser/components/newtab/test/browser/browser_asrouter_cfr.js :: test_matchPattern :: line 385
[task 2019-04-04T15:39:55.156Z] 15:39:55 INFO - Stack trace:
[task 2019-04-04T15:39:55.157Z] 15:39:55 INFO - chrome://mochitests/content/browser/browser/components/newtab/test/browser/browser_asrouter_cfr.js:test_matchPattern:385
[task 2019-04-04T15:39:55.158Z] 15:39:55 INFO - chrome://mochikit/content/browser-test.js:Tester_execTest/<:1116
[task 2019-04-04T15:39:55.159Z] 15:39:55 INFO - chrome://mochikit/content/browser-test.js:Tester_execTest:1144
[task 2019-04-04T15:39:55.160Z] 15:39:55 INFO - chrome://mochikit/content/browser-test.js:nextTest/<:1000
[task 2019-04-04T15:39:55.161Z] 15:39:55 INFO - chrome://mochikit/content/tests/SimpleTest/SimpleTest.js:SimpleTest.waitForFocus/waitForFocusInner/focusedOrLoaded/<:803
[task 2019-04-04T15:39:55.163Z] 15:39:55 INFO - GECKO(4427) | ++DOCSHELL 0x7feb3dadd800 == 7 [pid = 4427] [id = {efa43378-0ff4-464c-9eca-53b57fa4c772}]
[task 2019-04-04T15:39:55.164Z] 15:39:55 INFO - GECKO(4427) | ++DOMWINDOW == 15 (0x7feb3aa875c0) [pid = 4427] [serial = 17] [outer = (nil)]
[task 2019-04-04T15:39:55.165Z] 15:39:55 INFO - GECKO(4427) | ++DOMWINDOW == 16 (0x7feb42e95c00) [pid = 4427] [serial = 18] [outer = 0x7feb3aa875c0]
[task 2019-04-04T15:39:55.167Z] 15:39:55 INFO - GECKO(4427) | ++DOMWINDOW == 17 (0x7feb42e98000) [pid = 4427] [serial = 19] [outer = 0x7feb3aa875c0]
[task 2019-04-04T15:39:55.168Z] 15:39:55 INFO - GECKO(4427) | ++DOMWINDOW == 18 (0x7feb3d815c00) [pid = 4427] [serial = 20] [outer = 0x7feb3aa875c0]
[task 2019-04-04T15:39:55.460Z] 15:39:55 INFO - Not taking screenshot here: see the one that was previously logged
[task 2019-04-04T15:39:55.462Z] 15:39:55 INFO - TEST-UNEXPECTED-FAIL | browser/components/newtab/test/browser/browser_asrouter_cfr.js | Navigated to a new page but not a match - 0 == 1 - JS frame :: chrome://mochitests/content/browser/browser/components/newtab/test/browser/browser_asrouter_cfr.js :: test_matchPattern :: line 390
[task 2019-04-04T15:39:55.464Z] 15:39:55 INFO - Stack trace:
[task 2019-04-04T15:39:55.465Z] 15:39:55 INFO - chrome://mochitests/content/browser/browser/components/newtab/test/browser/browser_asrouter_cfr.js:test_matchPattern:390
[task 2019-04-04T15:39:55.467Z] 15:39:55 INFO - chrome://mochikit/content/browser-test.js:Tester_execTest/<:1116
[task 2019-04-04T15:39:55.469Z] 15:39:55 INFO - chrome://mochikit/content/browser-test.js:Tester_execTest:1144
[task 2019-04-04T15:39:55.470Z] 15:39:55 INFO - chrome://mochikit/content/browser-test.js:nextTest/<:1000
[task 2019-04-04T15:39:55.472Z] 15:39:55 INFO - chrome://mochikit/content/tests/SimpleTest/SimpleTest.js:SimpleTest.waitForFocus/waitForFocusInner/focusedOrLoaded/<:803
[task 2019-04-04T15:39:55.521Z] 15:39:55 INFO - GECKO(4427) | ++DOCSHELL 0x7f71bb6a0800 == 1 [pid = 4652] [id = {e049790d-0964-484d-ba86-a9a95df8169e}]
[task 2019-04-04T15:39:55.618Z] 15:39:55 INFO - GECKO(4427) | ++DOMWINDOW == 1 (0x7f71bc544d40) [pid = 4652] [serial = 1] [outer = (nil)]
[task 2019-04-04T15:39:55.755Z] 15:39:55 INFO - GECKO(4427) | ++DOMWINDOW == 2 (0x7f71bc5b0400) [pid = 4652] [serial = 2] [outer = 0x7f71bc544d40]
[task 2019-04-04T15:39:56.236Z] 15:39:56 INFO - GECKO(4427) | ### XPCOM_MEM_BLOAT_LOG defined -- logging bloat/leaks to /tmp/tmpRD1Zgf.mozrunner/runtests_leaks_tab_pid4679.log
[task 2019-04-04T15:39:56.358Z] 15:39:56 INFO - GECKO(4427) | ++DOMWINDOW == 3 (0x7f71bc41c000) [pid = 4652] [serial = 3] [outer = 0x7f71bc544d40]
[task 2019-04-04T15:39:56.637Z] 15:39:56 INFO - GECKO(4427) | [Parent 4427, Main Thread] WARNING: '!parent', file /builds/worker/workspace/build/src/netwerk/ipc/NeckoParent.cpp, line 955
[task 2019-04-04T15:39:56.673Z] 15:39:56 INFO - GECKO(4427) | Couldn't convert chrome URL: chrome://branding/locale/brand.properties
[task 2019-04-04T15:39:56.783Z] 15:39:56 INFO - Not taking screenshot here: see the one that was previously logged
[task 2019-04-04T15:39:56.786Z] 15:39:56 INFO - TEST-UNEXPECTED-FAIL | browser/components/newtab/test/browser/browser_asrouter_cfr.js | Navigated to a location that matches the pattern but within 15 mins - 0 == 1 - JS frame :: chrome://mochitests/content/browser/browser/components/newtab/test/browser/browser_asrouter_cfr.js :: test_matchPattern :: line 395
[task 2019-04-04T15:39:56.788Z] 15:39:56 INFO - Stack trace:
[task 2019-04-04T15:39:56.789Z] 15:39:56 INFO - chrome://mochitests/content/browser/browser/components/newtab/test/browser/browser_asrouter_cfr.js:test_matchPattern:395
[task 2019-04-04T15:39:56.791Z] 15:39:56 INFO - chrome://mochikit/content/browser-test.js:Tester_execTest/<:1116
[task 2019-04-04T15:39:56.792Z] 15:39:56 INFO - chrome://mochikit/content/browser-test.js:Tester_execTest:1144
[task 2019-04-04T15:39:56.794Z] 15:39:56 INFO - chrome://mochikit/content/browser-test.js:nextTest/<:1000
[task 2019-04-04T15:39:56.795Z] 15:39:56 INFO - chrome://mochikit/content/tests/SimpleTest/SimpleTest.js:SimpleTest.waitForFocus/waitForFocusInner/focusedOrLoaded/<:803
[task 2019-04-04T15:39:57.126Z] 15:39:57 INFO - GECKO(4427) | ++DOMWINDOW == 4 (0x7f71bc423800) [pid = 4652] [serial = 4] [outer = 0x7f71bc544d40]
[task 2019-04-04T15:39:57.447Z] 15:39:57 INFO - Not taking screenshot here: see the one that was previously logged
[task 2019-04-04T15:39:57.449Z] 15:39:57 INFO - TEST-UNEXPECTED-FAIL | browser/components/newtab/test/browser/browser_asrouter_cfr.js | www.example.com is a different host that also matches the pattern. - 0 == 2 - JS frame :: chrome://mochitests/content/browser/browser/components/newtab/test/browser/browser_asrouter_cfr.js :: test_matchPattern :: line 400
[task 2019-04-04T15:39:57.451Z] 15:39:57 INFO - Stack trace:

There are 26 total failures in the last 7 days on: windows7-32 debug, windows10-64-shippable opt, osx-10-10 debug, windows10-64 debug, linux64-shippable opt, windows7-32-shippable opt, linux64 debug, windows7-32 opt.

Recent failure log: https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=242006876&repo=mozilla-inbound&lineNumber=14917

11:01:29 INFO - TEST-START | browser/components/newtab/test/browser/browser_asrouter_cfr.js
11:01:33 INFO - TEST-UNEXPECTED-FAIL | browser/components/newtab/test/browser/browser_asrouter_cfr.js | Registered pattern matched the current location - 0 == 1 - JS frame :: chrome://mochitests/content/browser/browser/components/newtab/test/browser/browser_asrouter_cfr.js :: test_matchPattern :: line 385
11:01:33 INFO - Stack trace:
11:01:33 INFO - chrome://mochitests/content/browser/browser/components/newtab/test/browser/browser_asrouter_cfr.js:test_matchPattern:385
11:01:33 INFO - chrome://mochikit/content/browser-test.js:Tester_execTest/<:1116
11:01:33 INFO - chrome://mochikit/content/browser-test.js:Tester_execTest:1144
11:01:33 INFO - chrome://mochikit/content/browser-test.js:nextTest/<:1000
11:01:33 INFO - chrome://mochikit/content/tests/SimpleTest/SimpleTest.js:SimpleTest.waitForFocus/waitForFocusInner/focusedOrLoaded/<:803
11:01:33 INFO - GECKO(6996) | ++DOCSHELL 00000251CD949000 == 7 [pid = 3372] [id = {65e7bcba-b9d4-4564-8d7d-8524209cec33}]
11:01:33 INFO - GECKO(6996) | ++DOMWINDOW == 19 (00000251DDD92D40) [pid = 3372] [serial = 19] [outer = 0000000000000000]
11:01:33 INFO - GECKO(6996) | ++DOMWINDOW == 20 (00000251D95A9C00) [pid = 3372] [serial = 20] [outer = 00000251DDD92D40]
11:01:33 INFO - GECKO(6996) | ++DOMWINDOW == 21 (00000251D8312C00) [pid = 3372] [serial = 21] [outer = 00000251DDD92D40]
11:01:33 INFO - GECKO(6996) | ++DOMWINDOW == 22 (00000251D95AE800) [pid = 3372] [serial = 22] [outer = 00000251DDD92D40]
11:01:33 INFO - Not taking screenshot here: see the one that was previously logged

Tim, could you please assign this to someone?

Flags: needinfo?(tspurway)
Whiteboard: [retriggered] → [retriggered][stockwell needswork:owner]

Kate, could you have a quick look at this for severity and effort?

Flags: needinfo?(tspurway) → needinfo?(khudson)

Looks like an intermittent failure for the test_matchPattern test that loads http://example.com/. Any idea why that might be :andreio? Is there a quick fix you can think of?

Flags: needinfo?(khudson) → needinfo?(andrei.br92)
Assignee: nobody → andrei.br92
Flags: needinfo?(andrei.br92)
Pushed by aoprea@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/96802be91766
Fix intermittent newtab/browser_asrouter_cfr.js r=k88hudson
Status: NEW → RESOLVED
Closed: 7 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 68
Component: Activity Streams: Newtab → New Tab Page
You need to log in before you can comment on or make changes to this bug.