All users were logged out of Bugzilla on October 13th, 2018

Preferences: Add Apply button, Expand on click & Remember Last Used

VERIFIED INVALID

Status

--
enhancement
VERIFIED INVALID
17 years ago
14 years ago

People

(Reporter: mrtech, Assigned: bugs)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Just wondering if the Preferences can be updated to do the following:

- I occationally want to make sure that my settings are applied while still
looking through other options and adding an Apply button would be really helpful.

- When clicking on a top most Preference Option like Advanced or Appearance to
have it automatically expand and optionally to collapse the previous menu.  More
importantly is the expand the one clicked, this would save on clicks.  Right now
only clicking on the triangle will expand, a nice to have would be to also do
this when clicking on the title itself also.

- Remembering the last selected preference menu & submenu would be a god send, I
constantly have to switch from a Proxied environment and a non-Proxy environment
and have to click through the menus.  I know the behavior should mimic NS, but
this would just be a nice one to remember the last selected.

Comment 1

17 years ago
please limit bugs to a single request

* apply button has been discussed somewhere
* expand headings on click was discussed somewhere
* remember last selected category was discussed somewhere

since all three bugs already exist, i'm marking this bug as invalid, if you 
need help finding them, please visit irc.mozilla.org #mozillazine and explain 
you need help using bugzilla to find some preference dialog RFEs
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → INVALID
mass-verification of Invalid bugs.

if you don't think the report is invalid, please check to see if it has already
been reported (it might be a duplicate instead). otherwise, make sure that there
are steps (a valid test case) that clearly display the issue as an unexpected
defect.

mail filter string for bugspam: SequoiadendronGiganteum
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.