escape codes are not converted to characters when saving files

VERIFIED DUPLICATE of bug 76799

Status

--
major
VERIFIED DUPLICATE of bug 76799
17 years ago
2 years ago

People

(Reporter: bugzilla-mozilla, Assigned: law)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.1a+) Gecko/20020621
BuildID:    2002062109

In filenames, characters other than 0-9,A-Z,a-z, or the _ . - , characters are
saved with URI escape codes (space becomes %20, ä becomes %E4, etc.)

Reproducible: Always
Steps to Reproduce:
1. Find a file with a space or other character not specified above.
2. Save it.

Actual Results:  Characters are still in URL escape codes.

Expected Results:  Converted the characters to standard ASCII codes. (Or
JIS/SJIS/ISO-2022-JP codes for Japanese, etc.)

Comment 1

17 years ago
Actually, no.

on ntfs, we have Unicode available, we should use it.

on fat, we should so whatever ms suggests.
Assignee: Matti → law
Component: Browser-General → File Handling
QA Contact: imajes-qa → sairuh
(Reporter)

Comment 2

17 years ago
Agreed. Well, for non-ASCII characters use Unicode, otherwise just use ASCII.
(Why waste two bits when you can use only one?)
Dup of "File...Save As is not unescaping filenames"

*** This bug has been marked as a duplicate of 76799 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 4

16 years ago
vrfy dupe
Status: RESOLVED → VERIFIED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.