Firefox freezes when inspecting large POST data

RESOLVED FIXED in Firefox 68

Status

defect
P2
normal
RESOLVED FIXED
2 months ago
26 days ago

People

(Reporter: Honza, Assigned: hemakshis)

Tracking

(Regressed 1 bug)

unspecified
Firefox 68

Firefox Tracking Flags

(firefox68 fixed)

Details

Attachments

(1 attachment)

STR:

  1. Open DevTools, select the Network panel
  2. Check the Perist Logs check-box in the panel's toolbar (just to make sure to see POST request after navigation)
  3. POST big ~2MB file (e.g. using <form>, or XHR)
  4. Select the POST request in the list
  5. Select Params side panel tab -> Firefox freezes

Expected:
No freeze

This is caused by React, which is rendering large binary data in the UI.
We should use similar technique as for large responses, see bug 1498565.

Honza

Priority: -- → P3
Priority: P3 → P2
Assignee

Comment 1

2 months ago

Hi @honza,

I was trying to reproduce the error, but don't know why I keep getting a 413 status saying POST data too large.
I'm using XHR to send the data. Using the data from http://api.nobelprize.org/v1/prize.json (although it's not too large < 2MB)
Here's the link I am using to reproduce it http://bugzilla-tests.glitch.me/bugs/1542172.
Can you please have a look?

Thanks!
Hemakshi

Flags: needinfo?(odvarko)

I am seeing the same error (413). It looks like the glitch.me server defines some limits for POSTed data.

I am testing with my local HTTP server, using a simple HTML <form method="post">

Honza

Flags: needinfo?(odvarko)
Assignee

Comment 3

2 months ago

Hi @honza,

I was able to reproduce it (had to change the limit in my bodyParser).
So, I guess we have to use the same technique as done in Bug #1498565 ?

Flags: needinfo?(odvarko)

(In reply to Hemakshi Sachdev [:hemakshis] from comment #3)

I was able to reproduce it (had to change the limit in my bodyParser).
So, I guess we have to use the same technique as done in Bug #1498565 ?

I think so, but before that we should test whether the performance problem (in CodeMirror) isn't caused by one super long line (i.e. no new lines characters in the POST data body). (I've got a feedback that long lines could be an issue for Code Mirror)

Can you please check that?

Thanks!
Honza

Flags: needinfo?(odvarko)
Assignee: nobody → sachdev.hemakshi
Status: NEW → ASSIGNED
Assignee

Comment 5

a month ago

Truncate the Request Payload if it exceeds the `devtools.netmonitor.requestBodyLimit` pref and show `Request has been truncated` error in the Params Tab

Comment 6

a month ago
Pushed by jodvarko@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/8e100a978832
Firefox freezes when inspecting large POST data. r=Honza

Comment 7

a month ago
bugherder
Status: ASSIGNED → RESOLVED
Last Resolved: a month ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 68
Regressions: 1546706
You need to log in before you can comment on or make changes to this bug.