Python exception checking Rust version when bootstrapping for Android: AttributeError: 'unicode' object has no attribute 'version'

RESOLVED FIXED in Firefox 68

Status

defect
RESOLVED FIXED
2 months ago
2 months ago

People

(Reporter: bholley, Assigned: bholley)

Tracking

unspecified
mozilla68

Firefox Tracking Flags

(firefox68 fixed)

Details

Attachments

(2 attachments)

Assignee

Description

2 months ago

I have a patch. I'm not sure why this didn't bite other people.

Assignee

Comment 1

2 months ago
Posted file Console Log
Assignee

Updated

2 months ago
Summary: Python exception checking Rust version when bootstrapping for Android → Python exception checking Rust version when bootstrapping for Android: AttributeError: 'unicode' object has no attribute 'version'
Assignee

Comment 2

2 months ago

Mozboot uses Python 2.7.3, along with the |unicode_literals| directive,
which makes string literals unicode by default. However, the
LooseVersion implementation that ships with Python throws an exception
when comparing against bare unicode strings, because it only checks for
StringType, not UnicodeType [1].

[1] https://github.com/enthought/Python-2.7.3/blob/master/Lib/distutils/version.py#L292

Duplicate of this bug: 1541992

Comment 4

2 months ago
Pushed by bholley@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/39c1b02a33f5
Avoid exception during Android bootstrap. r=glandium

Comment 5

2 months ago
bugherder
Status: NEW → RESOLVED
Last Resolved: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla68
You need to log in before you can comment on or make changes to this bug.