Closed Bug 1542396 Opened 6 months ago Closed 5 months ago

Image loading from cache does not get a PerformanceEntry

Categories

(Core :: Performance, defect, P3)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1113676
Tracking Status
firefox68 --- affected

People

(Reporter: whawkins, Assigned: whawkins)

Details

In violation of the the SPEC (https://w3c.github.io/resource-timing/#sec-resource-timing), we do not properly create PerformanceEntry-s for images that are loaded from the cache. Here is the relevant snippet from the SPEC test:

Resources that are retrieved from relevant application caches or local resources MUST be included as PerformanceResourceTiming objects in the Performance Timeline [PERFORMANCE-TIMELINE-2].
Priority: -- → P3

Can I get more background on this? Was this an oversight on our part or did we have concerns about the SPEC and made a decision not to implement?

smaug: would you know?

Flags: needinfo?(bugs)

I don't know about PerformanceEntries.
Given bug 822480, Valentin might know.

Flags: needinfo?(bugs) → needinfo?(valentin.gosu)

This is a known bug. I have a patch in bug 1113676 but unfortunately it also causes some tests to fail - sometimes the entry appears twice in the list. I haven't had time recently to figure it out, so help is appreciated.

Status: ASSIGNED → RESOLVED
Closed: 5 months ago
Flags: needinfo?(valentin.gosu)
Resolution: --- → DUPLICATE
Duplicate of bug: 1113676
You need to log in before you can comment on or make changes to this bug.