Closed Bug 1542799 Opened 9 months ago Closed 9 months ago

Clang format commit hook for git can't handle multiple files

Categories

(Firefox Build System :: Lint and Formatting, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1541409

People

(Reporter: farre, Unassigned)

Details

Install git hooks using:

$ ln -s $(pwd)/tools/lint/hooks_clang_format.py .git/hooks/pre-commit

Make changes to at least two files, e.g. dom/base/nsFrameLoader.cpp and dom/base/nsGlobalWindowOuter.cpp

Commit:

$ git commit -m wip
Processing 2 file(s)...
fatal: pathspec 'dom/base/nsFrameLoader.cpp dom/base/nsGlobalWindowOuter.cpp' did not match any files
Command to retrieve local files failed

Status: NEW → RESOLVED
Closed: 9 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1541409
You need to log in before you can comment on or make changes to this bug.