Closed Bug 1543027 Opened 8 months ago Closed 2 months ago

Snapping Picture-In-Picture videos to the left/right/top with the mouse displays thick white bars on the video's sides

Categories

(Toolkit :: Video/Audio Controls, defect, P2)

defect

Tracking

()

VERIFIED FIXED
mozilla71
Tracking Status
firefox71 --- verified

People

(Reporter: itiel_yn8, Assigned: mconley)

References

(Blocks 1 open bug)

Details

Attachments

(5 files)

Attached image Snapping to the right

STR:

  1. Use Windows
  2. Open any video in Picture-In-Picture mode
  3. Press Win key+left/right/up arrow keys

AR:
a. Snapping the video to the top once adds 2 big white bars to the video (one above the video and another on its bottom) covering half of the screen
b. Snapping the video to the right/left adds 2 white bars to the video (one on its right and another on its left). Also the video gets ~2x bigger
c. Snapping the video to the top twice makes the video look the same as in #b, but on the upper part of the screen
d. Snapping the video to the top thrice makes it go fullscreen, and adds a white bar to the video's bottom part

ER:
No white bars, and potentially no 2x bigger videos (?)

You'll need to open the third attachment here in a new tab to see the white bar at the bottom.

Priority: -- → P3
See Also: → 1546362
Depends on: 1546395
Depends on: 1546605
No longer depends on: 1546605
No longer depends on: 1546395

It seems we can disable Windows Aero snap for the PiP windows when it's of type "dialog".

Patch coming up.

Assignee: nobody → mconley
Priority: P3 → P2

This also seems to make the player window buttons work more reliably with touchscreens.

Duplicate of this bug: 1565495
Pushed by mconley@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/969b3828a301
Make Picture-in-Picture player window a dialog window type. r=JSON_voorhees
Status: NEW → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla71
Blocks: 1536747
Regressions: 1580733

I'm on the latest Nightly and this doesn't seem to be fixed, but bug 1543031 and bug 1536011 are fixed here, so this patch should be included in my Nightly.. I'm on Windows 10.
mconley, what info do you need to debug this?

Flags: needinfo?(mconley)

Can confirm what Itiel said, this is still reproducible on latest Nightly 71.0a1 (2019-09-16) (64-bit).
Mike, should we re-open this one or submit a new bug?

Attached video LatestNightly

Gah, when I was testing this, I was snapping with the mouse and not the keyboard. :(

Yes, I'll get a new bug on file.

Flags: needinfo?(mconley)
Summary: Snapping Picture-In-Picture videos to the left/right/top displays thick white bars on the video's sides → Snapping Picture-In-Picture videos to the left/right/top with the mouse displays thick white bars on the video's sides
Flags: qe-verify+

Confirmed issue with 68.0a1 (2019-04-09).
Verified fix with 71.0b5.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.