Closed Bug 1543158 Opened 8 months ago Closed 7 months ago

[Translate.Next] Consecutive approve/disapprove a suggestion ends up in gray page

Categories

(Webtools :: Pontoon, defect, P3)

defect

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: MikkCZ, Assigned: mathjazz)

Details

(Whiteboard: tn-testing-2)

Attachments

(3 files)

URL: https://mozilla-pontoon-staging.herokuapp.com/translate/cs/firefox/browser/browser/sanitize.ftl/?string=192605

Description:
I have started from an already approved string and tried to un-review it and approve it again. After several click, probably some race condition occurred and I ended with a page with background colour only.

Expected outcome:
The string should correctly change state each time the (✔️) button is clicked.

Steps to reproduce:

  1. Open a translation view on the URL above.
  2. Click on the (✔️) button several times (at least four or five times quickly).
  3. First I experienced some kind of lag before the string state changed. Eventually I ended with gray page with the URL changes to the next string https://mozilla-pontoon-staging.herokuapp.com/translate/cs/firefox/browser/browser/sanitize.ftl/?string=192618.

Note: I have noticed each time I click the (✔️) button, the machinery tabs are reloaded (or at least their headers). AFAIK this was not the case.

Attached file HTML.html

Here is the HTML I have copied our from the DevTools explorer. That should reflect the actual state of DOM at the moment.

And here are all the messaged from browser console. I am sorry for the error messages being shown in Czech. I can try to mass translated them for you back to English.

The same problem is reproducible with already rejected string.

Alternative STR:

  1. Open https://mozilla-pontoon-staging.herokuapp.com/translate/cs/firefox/browser/chrome/browser/search.properties/?string=74255
  2. Click on the (x) button quickly several time to un/reject the suggestion.
  3. The result is the some even though you haven't been moved to any other string. The URL is still https://mozilla-pontoon-staging.herokuapp.com/translate/cs/firefox/browser/chrome/browser/search.properties/?string=74255.
Priority: -- → P3

I'm unable to reproduce the "grey page" attached in Comment 1, nor the error attached in Comment 2.

However, we should still prevent multiple parallel review/submit requests.

Assignee: nobody → m
Status: NEW → ASSIGNED
Whiteboard: tn-testing-2
Status: ASSIGNED → RESOLVED
Closed: 7 months ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.