Closed Bug 1543325 Opened 5 years ago Closed 5 years ago

2.39 - 6.34% build times (windows2012-32-shippable, windows2012-64-shippable) regression on push 4bb96b9e1a3241c400b6fcdcd6ebf7e97fc5fcb9

Categories

(Firefox Build System :: General, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: igoldan, Unassigned)

References

(Regression)

Details

(Keywords: regression)

We have detected a build metrics regression from push:

https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=c8c67ca7b3d907c0a3c88fa40f07cccd281932c4&tochange=4bb96b9e1a3241c400b6fcdcd6ebf7e97fc5fcb9

As author of one of the patches included in that push, we need your help to address this regression.

Regressions:

6% build times windows2012-32-shippable opt nightly taskcluster-c5.4xlarge 4,636.97 -> 4,930.86
5% build times windows2012-32-shippable opt nightly taskcluster-c4.4xlarge 5,490.86 -> 5,780.75
2% build times windows2012-64-shippable opt nightly taskcluster-c4.4xlarge 6,091.57 -> 6,237.32

You can find links to graphs and comparison views for each of the above tests at: https://treeherder.mozilla.org/perf.html#/alerts?id=20372

On the page above you can see an alert for each affected platform as well as a link to a graph showing the history of scores for this test. There is also a link to a treeherder page showing the jobs in a pushlog format.

To learn more about the regressing test(s), please see: https://developer.mozilla.org/en-US/docs/Mozilla/Performance/Automated_Performance_Testing_and_Sheriffing/Build_Metrics

*** Please let us know your plans within 3 business days, or the offending patch(es) will be backed out! ***

Product: Testing → Firefox Build System
Flags: needinfo?(nfroyd)
No longer blocks: 1541068
Regressed by: 1541068

I think that's expected now that we're removing additional files during the PGO clobber step. mshal, do we have plans to transition Windows builds to 3-stage PGO so we could avoid this?

Status: NEW → RESOLVED
Closed: 5 years ago
Flags: needinfo?(nfroyd) → needinfo?(mshal)
Resolution: --- → WORKSFORME
OS: Windows → All

(In reply to Nathan Froyd [:froydnj] from comment #1)

I think that's expected now that we're removing additional files during the PGO clobber step. mshal, do we have plans to transition Windows builds to 3-stage PGO so we could avoid this?

Redirecting to chmanchester, since he's planning to work on Windows PGO this quarter I believe.

Flags: needinfo?(mshal) → needinfo?(cmanchester)

Yes, I believe I'm planning to work on 3-tier Windows PGO this quarter.

Flags: needinfo?(cmanchester)
Has Regression Range: --- → yes
You need to log in before you can comment on or make changes to this bug.