Closed Bug 1543345 Opened 1 year ago Closed 5 months ago

[Translate.Next] Implement and document Fluent Source Editor shortcuts

Categories

(Webtools :: Pontoon, defect, P3)

defect

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: adrian, Assigned: mathjazz)

References

Details

Attachments

(1 file)

These shortcuts will have to be slightly different from those in the generic editor, because of our usage of Ace (it doesn't make sense to send on 'Enter' in a multi-line editor, for example).

Duplicate of this bug: 1557925
Duplicate of this bug: 1555239
Summary: [Translate.Next] Implement and document Fluent Editor shortcuts → [Translate.Next] Implement and document Fluent Source Editor shortcuts

This bug might be affected by the changes we'll make in bug 1563457.

Depends on: 1563457
Assignee: nobody → m
Status: NEW → ASSIGNED

It turns out as part of this bug we should also generalize handling of keyboard shortcuts and thus make it less editor-dependent.

That means changes to bug 1563457 will have little to no impact here. Hence, I'm removing the dependency.

(Also, we might be able to fix bug 1563457 without replacing the Ace editor).

No longer depends on: 1563457
Status: ASSIGNED → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.