Open Bug 1543454 Opened 9 months ago Updated 4 months ago

Don't include single-character usernames in the save password prompt

Categories

(Toolkit :: Password Manager, enhancement, P3)

enhancement

Tracking

()

REOPENED

People

(Reporter: MattN, Unassigned)

References

(Blocks 1 open bug)

Details

(Whiteboard: [passwords:capture-UI])

User Story

Proposed solution:
Blank the username value if it's a single character before prompting.

The user can manually add a single-character username from the doorhanger before saving.

If a login already have a single-character username saved then we should continue to record its use (timestamps and counts) and shouldn't prompt for a change even if the login was manually typed and not autofilled.

Attachments

(1 file)

Sites use single-character usernames to avoid the correct username from being saved. It's probably not useful to save a single-character usernames as many sites wouldn't allow such a short username and the user likely knows their own username and can type the one character.

This should fix sites like us.hsbc.com which uses a value of "x" in a hidden username field. (It actually had "X ")

Assignee: nobody → sfoster
Status: NEW → ASSIGNED
Pushed by sfoster@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/0929ce862892
Set single-character usernames to null when prompting to save password. r=MattN
Status: ASSIGNED → RESOLVED
Closed: 9 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla68

I have validated this fix on several (about 10) random sites.

If the username input is only 1 character long, then the prompt to save credentials will only catch the password input. In the prompt to save credentials, the user can input the 1-character username and save it. After that, the 1-character username will properly be auto-filled, along with the password.
If the username is 2 letters long, the prompt to save credentials will catch both the 2-character username and the password. The auto-fill feature will properly work as intended.

Considering all the above, I will consider this issue fixed and verified. Thank you.

Status: RESOLVED → VERIFIED
Pushed by sfoster@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/5d7b8187380f
Backed out changeset 0929ce862892, its not the correct fix for known sites with this symptom at this time.
Assignee: sfoster → nobody
Status: VERIFIED → REOPENED
Priority: P2 → P3
Resolution: FIXED → ---
Whiteboard: [passwords:capture-UI]
Target Milestone: mozilla68 → ---
Status: REOPENED → RESOLVED
Closed: 9 months ago9 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla68
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Target Milestone: mozilla68 → ---
You need to log in before you can comment on or make changes to this bug.