Closed Bug 1543509 Opened 2 years ago Closed 1 year ago

Feature request - recovery from closing the wrong website (Undo)

Categories

(Firefox :: Session Restore, enhancement)

66 Branch
enhancement
Not set
normal

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: keepitsimplestupid, Unassigned)

Details

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:66.0) Gecko/20100101 Firefox/66.0

Steps to reproduce:

I spend a lot of time on www.allaboutcircuits.com and www.electro-tech-online.com which is a forum based website. When there are pics attached you can easily close the wrong tab.

I want a simple UNDO that works and preserves the underlying history.

You have to go to bookends, then history, the recently closed tabs or recently closed windows

then find it.

the problem is that all of the underlying (BACK) buttons are gone too. I just want to be able to get back to where I was as if I did not click close.

In essence want available from the bookend ICON.

Restore recently closed tab and underlying history.

Good programming practice is to allow Undo.

Actual results:

recovers just the tab.

Expected results:

Recover that tab and the underlying history for that tab so back works as if close never happened.

Hi,

I will add a component in order to get an opinion on this.

Thank you for reporting!

Type: defect → enhancement
Component: Untriaged → Session Restore

This feature already exists and has been in Firefox since, well, I can remember: go to the 'History' menu and you can find the 'Recently Closed Tabs' and 'Recently Closed Windows' menus, which contain an up-to-date list. There are hotkeys available too: Ctrl+Shift+T to re-open the most recently closed tab and Ctrl+Shift+N to re-open the most recently closed window, including its tabs.

Status: UNCONFIRMED → RESOLVED
Closed: 1 year ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.