Closed Bug 1543517 Opened 4 months ago Closed 29 days ago

Enable direct UTF-8 compilation of all web-visible scripts in beta

Categories

(Core :: DOM: Core & HTML, enhancement)

enhancement
Not set

Tracking

()

RESOLVED FIXED
mozilla70
Tracking Status
firefox68 --- wontfix
firefox69 --- fixed
firefox70 --- fixed

People

(Reporter: Waldo, Assigned: Waldo)

References

(Blocks 2 open bugs)

Details

Attachments

(2 files)

Similar to bug 1543514, but for flipping on individual things -- usually temporarily gated by preferences -- in nightly/beta.

This bug will probably either depend on individual separate bugs as each caller gets opted in to direct UTF-8 (with bugs filed on demand for each caller being switched), or it'll have separate patches for separate prefs for separate callers.

Depends on: 1553502
Depends on: 1554362

UTF-8 parsing in nightly has been enabled ever since it landed -- that is, the pref for it has always defaulted to true for nightly. So let's remove nightly from the summary here and make this purely beta-focused.

Summary: Enable direct UTF-8 compilation of all web-visible scripts in nightly/beta → Enable direct UTF-8 compilation of all web-visible scripts in beta
Attachment #9079544 - Attachment description: Bug 1543517 - Enable UTF-8 parsing of external (non-inline) and worker scripts unconditionally in nightly builds. r=bzbarsky → Bug 1543517 - Enable UTF-8 parsing of external (non-inline) and worker scripts unconditionally. r=bzbarsky
Pushed by jwalden@mit.edu:
https://hg.mozilla.org/integration/autoland/rev/72f73483711f
Enable UTF-8 parsing of external (non-inline) and worker scripts unconditionally.  r=bzbarsky

Comment on attachment 9079545 [details]
Bug 1543517 - Enable UTF-8 parsing of external (non-inline) and worker scripts unconditionally in beta builds (in suitable fashion to ride the trains into release). r=bzbarsky

Beta/Release Uplift Approval Request

  • User impact if declined: Faster, more memory-efficient UTF-8 parsing of scripts on the web will be deferred from Firefox 69 to Firefox 70 -- September 3 to October 22. This isn't the end of the world, but for the reasons I note below, I think the reward to shipping earlier outweighs the costs of shipping later.
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Worker scripts have been parsed as UTF-8 since late May, in nightly. <script> elements with external source have been parsed as UTF-8 since mid-June. These are extremely common features of web pages; basically every web page runs this code.

So all these code paths have been well-exercised for a month or more in nightly. Without this patch, they will be exercised six more weeks in nightly, then a month and a half in beta (with ongoing nightly testing in parallel, of course), before making release. With this patch being approved, they would be exercised seven weeks in beta (and in parallel in nightly), before making release.

Twelve weeks of nightly testing, for functionality central to the web, buys us very little over what 4-6 weeks of nightly testing buys us. Shipping this to users a month and a half earlier, on the other hand, is meaningful and is a bigger win. IMO.

If this were peripheral functionality users just might not happen to invoke in normal browsing, I wouldn't ask for a backport. But because this is so central, basically any amount of browsing exercises it, and so IMO the risk-adjusted value of shipping sooner outweighs the costs of delaying a bit longer.

  • String changes made/needed:
Attachment #9079545 - Flags: approval-mozilla-beta?
Status: ASSIGNED → RESOLVED
Closed: 29 days ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla70

Since the status are different for nightly and release, what's the status for beta?
For more information, please visit auto_nag documentation.

Comment on attachment 9079545 [details]
Bug 1543517 - Enable UTF-8 parsing of external (non-inline) and worker scripts unconditionally in beta builds (in suitable fashion to ride the trains into release). r=bzbarsky

I'm wishing this request came a bit earlier in the cycle than it did, but this code has been well-tested on Nightly and any regressions should be immediately apparent since it involves code that any site with a <script src="..."> tag (i.e. pretty much all of them) will end up hitting. We still have a bit over 4 weeks until RC and we can always pref this back off if there's problems reported. Approved for 69.0b8.

Attachment #9079545 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
You need to log in before you can comment on or make changes to this bug.