Intermittent /resource-timing/resource-timing-level1.sub.html | 'iframe 250ms delay in headers does not affect responseStart' - assert_greater_than_equal: Delay after HTTP/1.1 status should not affect 'responseStart'. expected a number

RESOLVED DUPLICATE of bug 1527172

Status

()

defect
P5
normal
RESOLVED DUPLICATE of bug 1527172
3 months ago
2 months ago

People

(Reporter: intermittent-bug-filer, Unassigned)

Tracking

({intermittent-failure, regression})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [stockwell disabled])

Attachments

(1 attachment)

Reporter

Description

3 months ago
treeherder

#[markdown(off)]
Filed by: aciure [at] mozilla.com

https://treeherder.mozilla.org/logviewer.html#?job_id=239575621&repo=mozilla-central

https://queue.taskcluster.net/v1/task/Unnf9Le8QECCW8Zg23PGJQ/runs/0/artifacts/public/logs/live_backing.log

task 2019-04-11T05:37:41.014Z] 05:37:41 INFO - TEST-START | /resource-timing/resource-timing-level1.sub.html
[task 2019-04-11T05:37:41.015Z] 05:37:41 INFO - Closing window 251
[task 2019-04-11T05:38:14.387Z] 05:38:14 INFO -
[task 2019-04-11T05:38:14.387Z] 05:38:14 INFO - TEST-PASS | /resource-timing/resource-timing-level1.sub.html | 'link (Populate cache): The initial request populates the cache (if appropriate).
[task 2019-04-11T05:38:14.388Z] 05:38:14 INFO - TEST-PASS | /resource-timing/resource-timing-level1.sub.html | 'link (Potentially Cached): Immediately fetch the same URL, exercising the cache hit path (if any).
[task 2019-04-11T05:38:14.388Z] 05:38:14 INFO - TEST-PASS | /resource-timing/resource-timing-level1.sub.html | 'iframe: 250ms delay before 'responseStart', another 250ms delay before 'responseEnd'.
[task 2019-04-11T05:38:14.388Z] 05:38:14 INFO - TEST-PASS | /resource-timing/resource-timing-level1.sub.html | 'xmlhttprequest: 250ms delay before 'responseStart', another 250ms delay before 'responseEnd'.
[task 2019-04-11T05:38:14.388Z] 05:38:14 INFO - TEST-PASS | /resource-timing/resource-timing-level1.sub.html | 'script: 250ms delay before 'responseStart', another 250ms delay before 'responseEnd'.
[task 2019-04-11T05:38:14.388Z] 05:38:14 INFO - TEST-PASS | /resource-timing/resource-timing-level1.sub.html | 'link: 250ms delay before 'responseStart', another 250ms delay before 'responseEnd'.
[task 2019-04-11T05:38:14.388Z] 05:38:14 INFO - TEST-PASS | /resource-timing/resource-timing-level1.sub.html | 'iframe (Redirected): 250ms delay before 'redirectEnd', another 250ms delay before 'responseStart'.
[task 2019-04-11T05:38:14.388Z] 05:38:14 INFO - TEST-PASS | /resource-timing/resource-timing-level1.sub.html | 'xmlhttprequest (Redirected): 250ms delay before 'redirectEnd', another 250ms delay before 'responseStart'.
[task 2019-04-11T05:38:14.388Z] 05:38:14 INFO - TEST-PASS | /resource-timing/resource-timing-level1.sub.html | 'script (Redirected): 250ms delay before 'redirectEnd', another 250ms delay before 'responseStart'.
[task 2019-04-11T05:38:14.388Z] 05:38:14 INFO - TEST-PASS | /resource-timing/resource-timing-level1.sub.html | 'link (Redirected): 250ms delay before 'redirectEnd', another 250ms delay before 'responseStart'.
[task 2019-04-11T05:38:14.388Z] 05:38:14 INFO - TEST-UNEXPECTED-FAIL | /resource-timing/resource-timing-level1.sub.html | 'iframe 250ms delay in headers does not affect responseStart' - assert_greater_than_equal: Delay after HTTP/1.1 status should not affect 'responseStart'. expected a number greater than or equal to 19090 but got 18960
[task 2019-04-11T05:38:14.388Z] 05:38:14 INFO - test/<@http://web-platform.test:8000/resource-timing/resource-timing-level1.js:227:29
[task 2019-04-11T05:38:14.389Z] 05:38:14 INFO - createOnloadCallbackFn/</<@http://web-platform.test:8000/resource-timing/resource-timing-level1.js:478:29
[task 2019-04-11T05:38:14.389Z] 05:38:14 INFO - assertInvariants/<@http://web-platform.test:8000/resource-timing/resource-timing-level1.js:309:25
[task 2019-04-11T05:38:14.389Z] 05:38:14 INFO - Test.prototype.step@http://web-platform.test:8000/resources/testharness.js:1587:25
[task 2019-04-11T05:38:14.389Z] 05:38:14 INFO - Test.prototype.step_func/<@http://web-platform.test:8000/resources/testharness.js:1611:35
[task 2019-04-11T05:38:14.389Z] 05:38:14 INFO - Test.prototype.step_timeout/<@http://web-platform.test:8000/resources/testharness.js:1645:22
[task 2019-04-11T05:38:14.389Z] 05:38:14 INFO - Test.prototype.step@http://web-platform.test:8000/resources/testharness.js:1587:25
[task 2019-04-11T05:38:14.389Z] 05:38:14 INFO - Test.prototype.step_func/<@http://web-platform.test:8000/resources/testharness.js:1611:35
[task 2019-04-11T05:38:14.389Z] 05:38:14 INFO - .......
[task 2019-04-11T05:38:14.390Z] 05:38:14 INFO - TEST-OK | /resource-timing/resource-timing-level1.sub.html | took 33371ms
[task 2019-04-11T05:38:15.032Z] 05:38:15 INFO - Closing logging queue
[task 2019-04-11T05:38:15.032Z] 05:38:15 INFO - queue closed
[task 2019-04-11T05:38:15.036Z] 05:38:15 INFO - Setting up ssl
[task 2019-04-11T05:38:15.677Z] 05:38:15 INFO - certutil |
[task 2019-04-11T05:38:15.697Z] 05:38:15 INFO - certutil |
[task 2019-04-11T05:38:15.712Z] 05:38:15 INFO - certutil |
[task 2019-04-11T05:38:15.712Z] 05:38:15 INFO - Certificate Nickname Trust Attributes
[task 2019-04-11T05:38:15.712Z] 05:38:15 INFO - SSL,S/MIME,JAR/XPI
[task 2019-04-11T05:38:15.712Z] 05:38:15 INFO -
[task 2019-04-11T05:38:15.713Z] 05:38:15 INFO - web-platform-tests CT,,
[task 2019-04-11T05:38:15.713Z] 05:38:15 INFO -
[task 2019-04-11T05:38:17.453Z] 05:38:17 INFO - adb Granting important runtime permissions to org.mozilla.fennec_aurora
[task 2019-04-11T05:38:18.714Z] 05:38:18 INFO - adb launch_application: am start -W -n org.mozilla.fennec_aurora/org.mozilla.gecko.BrowserApp -a android.intent.action.VIEW --es env9 MOZ_PROCESS_LOG=/tmp/tmpO9MS2Epidlog --es env8 MOZ_CRASHREPORTER_NO_REPORT=1 --es args "-no-remote -profile /sdcard/tests/profile --marionette about:blank" --es env3 STYLO_THREADS=4 --es env2 MOZ_HIDE_RESULTS_TABLE=1 --es env1 R_LOG_VERBOSE=1 --es env0 MOZ_CRASHREPORTER=1 --es env7 MOZ_DISABLE_NONLOCAL_CONNECTIONS=1 --es env6 R_LOG_DESTINATION=stderr --es env5 MOZ_CRASHREPORTER_SHUTDOWN=1 --es env4 MOZ_LOG=signaling:3,mtransport:4,DataChannel:4,jsep:4 --es env10 R_LOG_LEVEL=6
[task 2019-04-11T05:38:20.287Z] 05:38:20 INFO - Starting runner
[task 2019-04-11T05:38:21.258Z] 05:38:21 INFO - TEST-START | /resource-timing/resource-timing-tojson.html
[task 2019-04-11T05:38:21.273Z] 05:38:21 INFO - Setting pref privacy.reduceTimerPrecision (false)
[task 2019-04-11T05:38:24.229Z] 05:38:24 INFO - .
[task 2019-04-11T05:38:24.229Z] 05:38:24 INFO - TEST-OK | /resource-timing/resource-timing-tojson.html | took 2974ms

Joel should this be disabled too: https://bugzilla.mozilla.org/buglist.cgi?quicksearch=esource-timing-level1.sub.html&list_id=14662906 ?

ni Cosmin in case the answer is yes.

Flags: needinfo?(jmaher)
Flags: needinfo?(csabou)

I would say we should disable this on android- there will still be failures on osx, maybe to be safe android and osx? We are at the 45+ failures/week rate and android wpt is in the process of changing right now yet it might be a few more weeks before it is done being worked on.

Flags: needinfo?(jmaher)
Flags: needinfo?(csabou)
Keywords: leave-open
Whiteboard: [stockwell disabled]

Comment 4

3 months ago
Pushed by csabou@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/d679d6a5d63f
Disable resource-timing-level1.sub.html on mac and android for frequent failures.
Comment hidden (Intermittent Failures Robot)
Status: NEW → RESOLVED
Closed: 2 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1527172
You need to log in before you can comment on or make changes to this bug.