Closed Bug 1543627 Opened 2 years ago Closed 1 year ago

Using the `-createProfile` argument opens a new window in a running instance and doesn't create a profile

Categories

(Toolkit :: Startup and Profile System, defect, P3)

defect

Tracking

()

RESOLVED FIXED
mozilla68
Tracking Status
firefox-esr60 --- unaffected
firefox66 --- unaffected
firefox67 --- unaffected
firefox68 --- fixed

People

(Reporter: standard8, Unassigned)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 file, 1 obsolete file)

STR

  1. Have a Firefox Nightly build running your default profile.
  2. Run /Applications/FirefoxNightly.app/Contents/MacOS/firefox -createProfile tags

Expected Results

=> A new profile is created on disk, nothing changes for the main Firefox Nightly process that's already running.

Actual Results

=> No profile is created, a new window is also opened in the existing Firefox Nightly instance.

Summary: Using the `-createProfile` argument opens a new window in a running instance → Using the `-createProfile` argument opens a new window in a running instance and doesn't create a profile

I've been half thinking of removing this argument entirely, I'm not sure how many folks actually use it or what for.

Priority: -- → P3

(In reply to Dave Townsend [:mossop] (he/him) from comment #1)

I've been half thinking of removing this argument entirely, I'm not sure how many folks actually use it or what for.

Wontfix for 67 (anecdotally I use that argument rather frequently, I suspect that Mozilla staff and QA are the primary consumers)

Ah, bad assumption on my part. This doesn't affect 67. I think this was probably caused by bug 469990. It'll probably work if you pass -no-remote too.

Probably not a very common use, I'll call this fix-optional for 68 so it drops off regression triage, though we should still have time to fix this before release.

Hi Yuri, setting n-i for you in case you're interested in working on this too. Thanks!

Flags: needinfo?(mozilla)
Attached patch thefix4.patch (obsolete) — Splinter Review

(In reply to Stephen A Pohl [:spohl] from comment #5)

Hi Yuri, setting n-i for you in case you're interested in working on this too. Thanks!

I added an exception for -createProfile and --createProfile so it doesn't activate the existing instance if either of these arguments is specified, and a new process instance is created instead.
Verified that the exception is processed correctly, although the process just quits right after the profile has been created (not sure if this is the expected behavior). I.e.,
./firefox --createProfile test
silently creates a new profile "test" (you can see it in about:profiles if you launch ./firefox normally afterwards) but doesn't show any UI, and quits immediately afterwards.

Flags: needinfo?(mozilla) → needinfo?(spohl.mozilla.bugs)
Attached patch PatchSplinter Review

Thank you for working on this!

(In reply to Yuri from comment #6)

I added an exception for -createProfile and --createProfile so it doesn't activate the existing instance if either of these arguments is specified, and a new process instance is created instead.
Verified that the exception is processed correctly, although the process just quits right after the profile has been created (not sure if this is the expected behavior). I.e.,
./firefox --createProfile test
silently creates a new profile "test" (you can see it in about:profiles if you launch ./firefox normally afterwards) but doesn't show any UI, and quits immediately afterwards.

Yes, this is the expected behavior. I have updated your patch to apply cleanly and reordered the command line arguments so that it remains readable if we have to add any more arguments to skip in the future.

Attachment #9061747 - Attachment is obsolete: true
Flags: needinfo?(spohl.mozilla.bugs)
Attachment #9061891 - Flags: review+
https://hg.mozilla.org/integration/mozilla-inbound/rev/c9918832d469c13bb49f895ca2f7562a3f7c19df
Bug 1543627: Allow for --createProfile cmd line arg to work on macOS when Firefox is already running. r=spohl
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla68
You need to log in before you can comment on or make changes to this bug.