Closed Bug 1543657 Opened 5 months ago Closed 5 months ago

Issues with Facebook chat/messenger

Categories

(Firefox :: General, defect, P1, blocker)

66 Branch
defect

Tracking

()

RESOLVED INVALID

People

(Reporter: marcoagpinto, Unassigned)

References

Details

Attachments

(1 file)

Hello!

While typing on Facebook chat, the text cursor moves to the left.

While attempting to move the cursor right, it closes the chat window like a crash.

Maybe there is an issue with JavaScript?

[Tracking Requested - why for this release]:
it is also reported on some other support channels that this behaviour is regressing in 66.0.3:
https://support.mozilla.org/questions/firefox?owner=all&tagged=bug1543657&show=all

could this be related to bug 1537609? this seems to have been the only js related change going into 66.0.3...

Flags: needinfo?(jorendorff)
Flags: needinfo?(jdemooij)

Is it an actual browser crash? In that case could you please go to about:crashes, open the right crash report and paste the URL here? That would help us track it down :)

Flags: needinfo?(marcoagpinto)

(In reply to Jan de Mooij [:jandem] from comment #4)

Is it an actual browser crash? In that case could you please go to about:crashes, open the right crash report and paste the URL here? That would help us track it down :)

The browser doesn't crash, but the private chat window on Facebook with whom I am chatting with closes (like a crash, it simply vanishes).

Thanks Marco. Would it be possible for you to use mozregression to help track it down? See https://mozilla.github.io/mozregression/quickstart.html

I can also give you a list of builds to download and test if that's easier.

(In reply to Jan de Mooij [:jandem] from comment #6)

Thanks Marco. Would it be possible for you to uses mozregression to help track it down? See https://mozilla.github.io/mozregression/quickstart.html

I can also give you a list of builds to download and test if that's easier.

I believe I won't have the time to track it down, but I am almost sure it didn't happen with 0.2 and it happens with 0.3

Flags: needinfo?(marcoagpinto)

Adam, I wonder if this may be related to bug 1498973 - can you take a look?

Flags: needinfo?(agashlin)

I'm disabling updates for 66.0.3 in the meantime.

Priority: -- → P1

I don't think bug 1498973 would have an affect on the cursor, but it could be related to the window disappearing. I'll try to reproduce.

Flags: needinfo?(agashlin)

I can reproduce it in nightly and 66.0.3, but not in 66.0.2. Stefan is going to try and find a regression window today.

Duplicate of this bug: 1543781

I'm not able to see the issue now, despite seeing it earlier today. So, I'm thinking this may actually be Facebook's bug.
I'm asking some other folks to test as well.

Todd, try again in a little while, as I think it's likely that Facebook is rolling out a fix already.

Flags: needinfo?(spcaller)

Thank You Liz, sorry to be so critical being in a computer training program right now Myself. These "bugs" can be annoying like a Moth in a disk drive! LOL - Todd

Flags: needinfo?(spcaller)

Marco, are you still seeing the original issue?

Flags: needinfo?(marcoagpinto)

(In reply to Liz Henry (:lizzard) (use needinfo) from comment #16)

Marco, are you still seeing the original issue?

Yes, I have just tried it.

It is still happening.

Flags: needinfo?(marcoagpinto)

Fb is doing a lot of staged rollouts, we dont all see the same website.
it might be one of the issue

I wasn't able to reproduce in my 64-bit Win10 1809 VM in 66.0.3, 32-bit or 64-bit, fwiw. It might be helpful to know what version of Windows you're running, Marco (run winver.exe).

(In reply to Adam Gashlin (he/him) [:agashlin] from comment #19)

I wasn't able to reproduce in my 64-bit Win10 1809 VM in 66.0.3, 32-bit or 64-bit, fwiw. It might be helpful to know what version of Windows you're running, Marco (run winver.exe).

I have the latest Windows 10 Pro x64.

(In reply to Marco A.G.Pinto [:marcoagpinto] from comment #20)

I have the latest Windows 10 Pro x64.

Thanks, but I'm wondering what exact version of Windows 10 that is, 1803 is still widespread though 1809 is the latest feature update so far. This is potentially interesting as bug 1498973 would only take effect on 1809 and up (though I doubt this is the issue).

(In reply to Adam Gashlin (he/him) [:agashlin] from comment #21)

(In reply to Marco A.G.Pinto [:marcoagpinto] from comment #20)

I have the latest Windows 10 Pro x64.

Thanks, but I'm wondering what exact version of Windows 10 that is, 1803 is still widespread though 1809 is the latest feature update so far. This is potentially interesting as bug 1498973 would only take effect on 1809 and up (though I doubt this is the issue).

Microsoft Windows [Version 10.0.17763.437]
1809

I have the issue on nightly on Linux

Severity: major → blocker
Summary: FF 66.0.3 and issues with Facebook chat → FF 66.0.3 and issues with Facebook chat/messenger

I have this in the console:

ErrorUtils caught an error: "Got unexpected null or undefined". Subsequent errors won't be logged; see https://fburl.com/debugjs.

reportError https://www.facebook.com/rsrc.php/v3/yN/r/0qg9Y2jnsYn.js:55
    applyWithGuard https://www.facebook.com/rsrc.php/v3/yN/r/0qg9Y2jnsYn.js:55
    a https://www.facebook.com/rsrc.php/v3iPlh4/yS/l/fr_FR/k-GUsJVvlWG.js:688
    za https://www.facebook.com/rsrc.php/v3/yi/r/Dn4NTDCXFOK.js:7
    Fa https://www.facebook.com/rsrc.php/v3/yi/r/Dn4NTDCXFOK.js:7
    Ga https://www.facebook.com/rsrc.php/v3/yi/r/Dn4NTDCXFOK.js:7
    Ka https://www.facebook.com/rsrc.php/v3/yi/r/Dn4NTDCXFOK.js:7
    Oa https://www.facebook.com/rsrc.php/v3/yi/r/Dn4NTDCXFOK.js:7
    Ma https://www.facebook.com/rsrc.php/v3/yi/r/Dn4NTDCXFOK.js:7
    Pa https://www.facebook.com/rsrc.php/v3/yi/r/Dn4NTDCXFOK.js:7
    xd https://www.facebook.com/rsrc.php/v3/yi/r/Dn4NTDCXFOK.js:7
    Zi https://www.facebook.com/rsrc.php/v3/yi/r/Dn4NTDCXFOK.js:7
    Rb https://www.facebook.com/rsrc.php/v3/yi/r/Dn4NTDCXFOK.js:7
    Bd https://www.facebook.com/rsrc.php/v3/yi/r/Dn4NTDCXFOK.js:7
    unstable_runWithPriority https://www.facebook.com/rsrc.php/v3iPlh4/yS/l/fr_FR/k-GUsJVvlWG.js:113
Flags: needinfo?(jorendorff)

Stabbing in the dark but maybe something with window.event or event.keyCode?

Flags: needinfo?(miket)
Flags: needinfo?(masayuki)
Flags: needinfo?(htsai)

There's some other people reporting the problem here, https://downdetector.com/status/facebook-messenger/map/ But no reply from FB yet.

The link from comment 26 indicates that this is not a Firefox-specific issue.

Randomness doesn't smell like that. I can't reproduce this. But anyone who can, please please, regression range. That is always the first thing to try to find with regression bugs. (unless if this is some change FB is doing.)

I can reproduce this issue on my wife's MacBook Pro. But neither of our accounts can reproduce it on my Macbook Pro.

With her FB account:
FF 66.0.3 - cursor moves back to the right while typing and backspace doesn't work
FF 68 (same laptop) - doesn't reproduce

With my FB account:
FF 66.0.3 (private window) - doesn't reproduce
FF 68 (same laptop) - doesn't reproduce

Tested 66.0.2 and the issue reproduces on it as well. Messenger.com works fine with that account though.

Summary: FF 66.0.3 and issues with Facebook chat/messenger → Issues with Facebook chat/messenger

OK, so now we know it isn't a change from 66.0.3. Though, Adam suggested that the restart from updating may have triggered new FB code for some people. If a fix from Facebook is rolling out that should be come clear over the next day. I'm also waiting on a response from Facebook engineers from our mailing list.

Any other testing or information people can provide is welcome.

Further evidence (Same thing happening in Chrome) https://twitter.com/kmlloren/status/1116277206047543296

Attached image Console output on Win10

FWIW this is console output on Windows 10 when this issue happens.

(Canceling ni? since sounds like a bug of FB's new code.)

Flags: needinfo?(masayuki)

(In reply to Andrew Overholt [:overholt] from comment #25)

Stabbing in the dark but maybe something with window.event or event.keyCode?

Thankfully, it seems not. /me knocks on wood.

Flags: needinfo?(miket)

99% sure this is resolved by Facebook but I'll leave the bug open for a few days to make 100% sure.

This wasn't on our side, closing.

Status: UNCONFIRMED → RESOLVED
Closed: 5 months ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.