Closed Bug 1543680 Opened 8 months ago Closed 8 months ago

Video controls are not displayed when returning from PIP

Categories

(Firefox for Android :: Audio/Video, defect, P2)

Firefox 68
ARM
Android
defect

Tracking

()

VERIFIED FIXED
Firefox 68
Tracking Status
firefox66 --- unaffected
firefox67 --- verified
firefox68 --- verified

People

(Reporter: sflorean, Assigned: petru)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 file)

Environment:
Device:

  • Google Pixel(Android Q);
  • Google Pixel (Android 9);
  • Nexus 6P (Android 8.1.0);

Build: Nightly 68.0a1 (2019-04-10);

Steps to reproduce:

  1. Go to http://dl3.webmfiles.org/elephants-dream.webm.
  2. Enter fullscreen.
  3. Tap on device home button.
  4. Tap on Fennec window.
  5. Tap on video once.

Expected result:
The video controls are displayed.

Actual result:
The video controls are not displayed.

Video: https://drive.google.com/file/d/1dkicS7VjS7-2831hRdP98wiQaa-duLJg/view?usp=sharing

Priority: -- → P2

Sorina, the test seems to have been done with 68 nightly but 67 is marked as affected as well, is it? Thanks

Flags: needinfo?(sorina.florean)

Pascal: Hi! Yes, this is also reproducible on Firefox 67.

I tested this on Samsung Galaxy Note 8 (Android 9) and I found a regression for this issue:

Last good revision: 90be1db1879c748ac5efa17942386853447febad
First bad revision: 28b82ee1219559a59a0614ec233daa2b8ba1453d

Pushlog:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=90be1db1879c748ac5efa17942386853447febad&tochange=28b82ee1219559a59a0614ec233daa2b8ba1453d

Petru: Hi! Can you please have a look?

Thanks.

Flags: needinfo?(sorina.florean) → needinfo?(petru.lingurar)
Regressed by: 1503978
Assignee: nobody → petru.lingurar
Status: NEW → ASSIGNED
Flags: needinfo?(petru.lingurar)

playbackState's default value is PlaybackState.STOPPED.
We can only enter PiP mode if media is playing but we don't save this playing
state.
If the user hasn't done anything to change this, like pause-play, when we check
the playbackState in BrowserApp to know to force fullscreen if still playing
we will not do so because the state is PlaybackState.STOPPED.

Pushed by ccoroiu@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/db411f941b86
Set playbackState as playing when entering in PiP mode; r=JanH

Keywords: checkin-needed
Status: ASSIGNED → RESOLVED
Closed: 8 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 68
Flags: qe-verify?
Flags: qe-verify? → qe-verify+

The fix looks minimal and our next Fennec Beta is on Tuesday, Petru could you request an uplift to beta please? Thanks

Flags: needinfo?(petru.lingurar)

Comment on attachment 9059026 [details]
Bug 1543680 - Set playbackState as playing when entering in PiP mode; r?JanH

Beta/Release Uplift Approval Request

  • User impact if declined: Broken UX after returning from PiP
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce: Enter PiP mode
    Press to return to the app
    Confirm the video is still playing in fullscreen and it's controls appear when tapping the video.
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Not risky. Very small, targeted code change.
  • String changes made/needed:
Flags: needinfo?(petru.lingurar)
Attachment #9059026 - Flags: approval-mozilla-beta?

Comment on attachment 9059026 [details]
Bug 1543680 - Set playbackState as playing when entering in PiP mode; r?JanH

Low-risk targeted fix, uplift approved for 67 beta 13, thanks.

Attachment #9059026 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
QA Whiteboard: [qa-triaged]

Hi!

I tested this on the latest version of Nightly 68.0a1 (2019-04-20) with OnePlus 5T(Android 9), Samsung Galaxy S8 (Android 9) and I wasn't able to reproduce the issue.

Due to my findings, I'll mark this issue as verified on Firefox 68.

Thank you.

Hello,

I performed the test case posted in Comment 0 on a Pixel 3 XL (Android 9).
On Beta 67.0b13 video controls are displayed when returning from PIP.

Due to my findings, I'll mark this issue as verified in Firefox 67.

Status: RESOLVED → VERIFIED
QA Whiteboard: [qa-triaged]
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.