Closed Bug 1543699 Opened 7 months ago Closed 7 months ago

Crash in [@ nsWebBrowser::Create]

Categories

(Core :: DOM: Core & HTML, defect, P1, critical)

67 Branch
defect

Tracking

()

RESOLVED FIXED
Fission Milestone M2
Tracking Status
firefox-esr60 --- unaffected
firefox66 --- wontfix
firefox67 + fixed
firefox68 --- fixed

People

(Reporter: philipp, Assigned: farre)

References

Details

(Keywords: crash, regression)

Crash Data

This bug is for crash report bp-9b64b64d-23c8-43ba-b14d-47a5f0190411.

Top 10 frames of crashing thread:

0 xul.dll nsWebBrowser::Create toolkit/components/browser/nsWebBrowser.cpp:107
1 xul.dll mozilla::dom::TabChild::Init dom/ipc/TabChild.cpp:526
2 xul.dll mozilla::dom::ContentChild::RecvPBrowserConstructor dom/ipc/ContentChild.cpp:1784
3 xul.dll mozilla::dom::PContentChild::OnMessageReceived ipc/ipdl/PContentChild.cpp:5574
4 xul.dll void mozilla::ipc::MessageChannel::DispatchMessage ipc/glue/MessageChannel.cpp:2078
5 xul.dll nsresult mozilla::ipc::MessageChannel::MessageTask::Run ipc/glue/MessageChannel.cpp:1968
6 xul.dll nsresult mozilla::SchedulerGroup::Runnable::Run xpcom/threads/SchedulerGroup.cpp:295
7 xul.dll nsThread::ProcessNextEvent xpcom/threads/nsThread.cpp:1179
8 xul.dll NS_ProcessNextEvent xpcom/threads/nsThreadUtils.cpp:482
9 xul.dll void mozilla::ipc::MessagePump::Run ipc/glue/MessagePump.cpp:110

crashes with this signature are regressing in volume during the 67 beta cycle.

Only one crash on 66, so wontfix for 66, but the 67 volume is noticable even though it went down in the last beta 9.

Hsinyi, could we get somebody assigned to this bug? There is an increase in 67 beta and I would like to make sure it doesn't come as a top crash when we reach release. Thanks.

Flags: needinfo?(htsai)

Bug 1541038 comment 8 shows a similar stack, a patch was landed that should have fixed this (see bug 1541038 comment 10 and bug 1541038 comment 17).

farre, was this already fixed?

Flags: needinfo?(afarre)
Priority: -- → P1

The stack looks like what I intended to fix with https://phabricator.services.mozilla.com/D27317. Let's keep track of the crash stats, if they disappear we'll have clear indications of it. Keeping the ni on me to do this.

Andreas, https://phabricator.services.mozilla.com/D27317 was checked into 68. Please use this bug to uplift this patch for 67 beta.

Assignee: nobody → afarre
Flags: needinfo?(htsai)

Andreas is on PTO and will be back on 23 Apr.

Fission Milestone: --- → M2
See Also: → 1541038

Nika, could you request an uplift of the patch as the reviewer? Andras being on PTO, we may miss the uplift window to beta. Thanks

Flags: needinfo?(nika)

I'll take this, since both farre and nika are out.

Flags: needinfo?(nika)
Flags: needinfo?(afarre)

Uplift request at https://bugzilla.mozilla.org/show_bug.cgi?id=1541038#c22 (not quite sure how we're tracking this across 2 bugs)

ni?'ing :pascalc just to make sure request is seen, since this needs to be in soon.

Flags: needinfo?(pascalc)
Flags: needinfo?(pascalc)
Status: NEW → RESOLVED
Closed: 7 months ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.