Closed Bug 1543810 Opened 7 months ago Closed 2 months ago

New Picture-in-Picture toggle is not detected when video has pointer-events: none

Categories

(Toolkit :: Video/Audio Controls, defect, P2)

defect

Tracking

()

VERIFIED FIXED
mozilla71
Tracking Status
firefox69 --- disabled
firefox70 --- disabled
firefox71 --- verified

People

(Reporter: mconley, Assigned: mconley)

References

(Blocks 1 open bug)

Details

Attachments

(3 files)

I suspect nsIDOMWindowUtils.nodesFromRect isn't hit-testing correctly in this case.

Attachment #9057666 - Attachment mime type: text/plain → text/html
Duplicate of this bug: 1545775

Hey emilio, here's another variation on nodesFromRect not getting me what I expected. This one, I think, is actually a nodesFromRect issue (unlike bug 1543805).

Do you know whether it's possible to modify nodesFromRect so that I can have it ignore pointer-events: none?

Flags: needinfo?(emilio)

It seems to me that with the aOnlyVisible option we should already be ignoring pointer-events:

https://searchfox.org/mozilla-central/rev/e7d9a8749303b39dadcc0e18ea0d60a570a68145/layout/painting/nsDisplayList.cpp#3102

That being said we do check for pointer-events none in a couple other places (grep for NS_STYLE_POINTER_EVENTS_NONE). Maybe some of those need a similar check.

Flags: needinfo?(emilio)

Upgrading priority now since this blocks having the toggle work on Amazon Prime videos.

Priority: P3 → P2
Assignee: nobody → mconley
Pushed by mconley@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/5aec6172783d
Make sure Picture-in-Picture toggle works on videos that have pointer-events: none. r=JSON_voorhees
https://hg.mozilla.org/integration/autoland/rev/a0c079f40c78
Regression test. r=JSON_voorhees
Backout by nerli@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/8a08bd085c4a
Backed out 2 changesets for failing in browser_togglePointerEventsNone.js CLOSED TREE

Hi noemi_erli,

Thanks for backing me out - sorry I caused a failure. I was pretty sure this passed in try. :/ Can you point me at one of the failures on autoland so I can examine the log? I'm having a hard time finding the orange that this caused for some reason.

Flags: needinfo?(nerli)
Pushed by mconley@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/49462f856061
Make sure Picture-in-Picture toggle works on videos that have pointer-events: none. r=JSON_voorhees
Attachment #9091531 - Attachment description: Bug 1543810 - Regression test. r?JSON_Voorhees → Bug 1543810 - Regression test to ensure that the Picture-in-Picture works with videos that have pointer-events: none. r?JSON_Voorhees
Pushed by mconley@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/54f895ee30ef
Regression test to ensure that the Picture-in-Picture works with videos that have pointer-events: none. r=JSON_voorhees
Status: NEW → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla71

Verified - fixed on latest Nightly 71.0a1 (2019-09-15) (64-bit) on Windows 10 x64.
Used the test case provided by Mike and also confirmed the fix for amazon prime videos in Bug 1546647.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.