Status

()

enhancement
RESOLVED FIXED
2 months ago
18 days ago

People

(Reporter: glasserc, Assigned: glasserc)

Tracking

67 Branch
Firefox 68
Points:
---

Firefox Tracking Flags

(firefox68 fixed)

Details

Attachments

(3 attachments)

Assignee

Description

2 months ago
  • Normandy actions report cumulative statuses at the end of every run. However, AddonStudyAction reports its status twice due to a quirk of code organization. This confuses the data for no reason.

  • In bug 1530508, I needed to choose a status for "recipe did not match", and I chose UptakeTelemetry.STATUS.CUSTOM_2_ERROR. This has led to a number of panicky questions when someone sees this for the first time. Since it's not actually an error, we should choose a safer-sounding status such as BACKOFF.

Assignee

Updated

2 months ago
Type: defect → enhancement
Assignee

Comment 2

2 months ago

Depends on D27362

Comment 5

2 months ago
Pushed by eglassercamp@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/3c62bdc7e166
Use BACKOFF for "recipe didn't match" r=mythmon
https://hg.mozilla.org/integration/autoland/rev/2f68e9e0c239
Don't finalize any action twice r=mythmon
https://hg.mozilla.org/integration/autoland/rev/be3f40425b52
Document different Normandy uptake telemetry values r=mythmon

Comment 6

2 months ago
bugherder
Status: NEW → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 68
Duplicate of this bug: 1545417
You need to log in before you can comment on or make changes to this bug.