Closed Bug 1543936 Opened 5 years ago Closed 5 years ago

4.49 - 5.47% tart / tscrollx (windows7-32-shippable) regression on push 6ce615da7b68745b5a703cf98d85b6d3d4072b74 (Wed Apr 10 2019)

Categories

(Toolkit :: Themes, defect, P2)

defect

Tracking

()

RESOLVED INVALID

People

(Reporter: Bebe, Unassigned)

References

(Regression)

Details

(Keywords: perf, regression, talos-regression)

Talos has detected a Firefox performance regression from push:

https://hg.mozilla.org/integration/autoland/pushloghtml?changeset=6ce615da7b68745b5a703cf98d85b6d3d4072b74

As author of one of the patches included in that push, we need your help to address this regression.

Regressions:

5% tscrollx windows7-32-shippable opt e10s stylo 1.01 -> 1.07
4% tart windows7-32-shippable opt e10s stylo 2.69 -> 2.81

You can find links to graphs and comparison views for each of the above tests at: https://treeherder.mozilla.org/perf.html#/alerts?id=20391

On the page above you can see an alert for each affected platform as well as a link to a graph showing the history of scores for this test. There is also a link to a treeherder page showing the Talos jobs in a pushlog format.

To learn more about the regressing test(s), please see: https://wiki.mozilla.org/Performance_sheriffing/Talos/Tests

For information on reproducing and debugging the regression, either on try or locally, see: https://wiki.mozilla.org/Performance_sheriffing/Talos/Running

*** Please let us know your plans within 3 business days, or the offending patch(es) will be backed out! ***

Our wiki page outlines the common responses and expectations: https://wiki.mozilla.org/Performance_sheriffing/Talos/RegressionBugsHandling

Blocks: 1534654
Component: General → Themes
Product: Testing → Toolkit
Regressed by: 1506913
Version: Version 3 → unspecified

Bug 1506913 caused a performance regression can you take a look

Flags: needinfo?(ntim.bugs)
Flags: needinfo?(dao+bmo)

Needinfo? on the author is sufficient.

Flags: needinfo?(dao+bmo)
Priority: -- → P2

(In reply to Florin Strugariu [:Bebe] from comment #0)

Talos has detected a Firefox performance regression from push:

https://hg.mozilla.org/integration/autoland/pushloghtml?changeset=6ce615da7b68745b5a703cf98d85b6d3d4072b74

The revision you linked was backed out (0) then relanded a bit later (1). Can you confirm that the first backout fixed the regression and that the revision that relanded regressed this again ?

5% tscrollx windows7-32-shippable opt e10s stylo 1.01 -> 1.07
4% tart windows7-32-shippable opt e10s stylo 2.69 -> 2.81

Is this only on Windows 7, not any other platform ? I have some ideas on how that patch could have caused a perf regression, but I'm pretty surprised it's win7 specific.

Flags: needinfo?(ntim.bugs) → needinfo?(fstrugariu)

After taking a better look at this it turns out this is a invalid alert because of the high noise of this test.

Here is a link with the three commits.
https://treeherder.mozilla.org/perf.html#/graphs?series=autoland,1922757,1,1&series=mozilla-inbound,1948772,1,1&highlightedRevisions=a5db25e4f477&highlightedRevisions=53c0f17ba52c&zoom=1554865741570.5151,1554974921963.6675,0.9265293307072214,1.1332709037409292

Sorry for the inconvenience!

Flags: needinfo?(fstrugariu)
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → INVALID
Has Regression Range: --- → yes
You need to log in before you can comment on or make changes to this bug.