Closed Bug 1543973 Opened 1 year ago Closed 1 year ago

Perma test_nsDefaultURIFixup_info.js | xpcshell return code: 0 when Gecko 68 merges to Beta on 2019-05-06

Categories

(Core :: DOM: Navigation, defect)

defect
Not set
normal
Points:
2

Tracking

()

VERIFIED FIXED
mozilla68
Iteration:
68.2 - Apr 1 - 14
Tracking Status
firefox-esr60 --- unaffected
firefox66 --- unaffected
firefox67 --- unaffected
firefox68 + verified

People

(Reporter: NarcisB, Assigned: daleharvey)

References

(Regression)

Details

Attachments

(1 file)

1555075140636	addons.manager	ERROR	startup failed: TypeError: Services.appinfo.version is undefined(resource://gre/modules/AddonManager.jsm:734:1) JS Stack trace: startup@AddonManager.jsm:734:1

Thats called from promiseStartupManager thats run in the test setup, the code thats failing looks like its:

 if (!MOZ_COMPATIBILITY_NIGHTLY) {
    PREF_EM_CHECK_COMPATIBILITY = PREF_EM_CHECK_COMPATIBILITY_BASE + "." +
                                  Services.appinfo.version.replace(BRANCH_REGEXP, "$1");
  }

Adding a check here would be a simple fix, it looks like there are a few quirks with using appinfo in the addon manager, and this is one of only 2 uses of MOZ_COMPATIBILITY_NIGHTLY so would be great if someone on from addons could suggest what would be the correct fix here, Kris you have any pointers? Thanks

Flags: needinfo?(dharvey) → needinfo?(kmaglione+bmo)
Assignee: nobody → dharvey
Flags: needinfo?(kmaglione+bmo)
Pushed by dharvey@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/ac38a6790d00
Switch to AppConstants to avoid appinfo conflict. r=mixedpuppy
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla68
Iteration: --- → 68.2 - Apr 1 - 14
Points: --- → 2
You need to log in before you can comment on or make changes to this bug.