Closed Bug 1544065 Opened 6 months ago Closed 6 months ago

reader mode's voice select widget doesn't open if clicking the name of the selected voice

Categories

(Toolkit :: Reader Mode, defect, P1)

defect

Tracking

()

VERIFIED FIXED
mozilla68
Tracking Status
firefox-esr60 --- unaffected
firefox66 --- wontfix
firefox67 --- verified
firefox68 --- verified

People

(Reporter: asa, Assigned: Gijs)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 file)

If you try to select a different voice by clicking on the name of the voice in the narrate panel, you don't get the pop-up for selecting alternate voices. You must click outside of the name of the voice, anywhere to the left or right in the gray box, to get the selector.

Tested in today's nightly build on x86 Windows 10

Wonder if this is a regression...

Assignee: nobody → gijskruitbosch+bugs
Status: NEW → ASSIGNED
Priority: -- → P1
Summary: reader mode's voice select widget is wonky → reader mode's voice select widget doesn't open if clicking the name of the selected voice
Pushed by gijskruitbosch@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/8ea3101cfbad
fix clicking on <span> tags inside voice selector in reader mode, r=eeejay
Status: ASSIGNED → RESOLVED
Closed: 6 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla68

Comment on attachment 9058266 [details]
Bug 1544065 - fix clicking on <span> tags inside voice selector in reader mode, r?eeejay

Beta/Release Uplift Approval Request

  • Feature/Bug causing the regression: Bug 1089326
  • User impact if declined: Selecting a different voice in reader mode fails to work properly in some situations
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce: See comment #0 / the subject of the bug. Clicking the text label of the voice select (as opposed to the whitespace around the text label) should also open the dropdown, and allow selecting a different voice.
  • List of other uplifts needed: n/a
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Single-line fix that makes sense given the regressing bug
  • String changes made/needed: None
Attachment #9058266 - Flags: approval-mozilla-beta?
Flags: qe-verify?

Comment on attachment 9058266 [details]
Bug 1544065 - fix clicking on <span> tags inside voice selector in reader mode, r?eeejay

Low risk, uplift approved for 67 beta 12, thanks.

Attachment #9058266 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Flags: qe-verify? → qe-verify+
QA Whiteboard: [qa-triaged]

Verified, that the issue is not reproducible on Nightly 68(20190417214729) an Windows 10 x64, MacOS 10.13 and Ubuntu 18.04
I'll verify it on 67 beta 12 also, when it will be available.

Verified, that the issue is not reproducible on Beta 67(20190418160535) on Windows 10 x64, MacOS 10.13 and Ubuntu 18.04

Status: RESOLVED → VERIFIED
QA Whiteboard: [qa-triaged]
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.