Closed Bug 1544373 Opened 6 months ago Closed 6 months ago

error unknown key StatementMacros in clang-format

Categories

(Firefox Build System :: Lint and Formatting, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1543492

People

(Reporter: freddyb, Unassigned)

References

(Blocks 1 open bug)

Details

Invoking clang-format with a path parameter is busted for me.
See output below:

Processing 1 file(s)...
YAML:28:19: error: unknown key 'StatementMacros'
StatementMacros: [MARKUPMAP, ASSERT_TRUE, ASSERT_FALSE, TEST, CHECK]
                  ^
Error reading /home/freddy/gecko/.clang-format: Invalid argument
The error occurred in the implementation of the invoked mach command.

This should never occur and is likely a bug in the implementation of that
command.
You can invoke |./mach busted| to check if this issue is already on file. If it
isn't, please use |./mach busted file| to report it. If |./mach busted| is
misbehaving, you can also inspect the dependencies of bug 1543241.

If filing a bug, please include the full output of mach, including this error
message.

The details of the failure are as follows:

AssertionError

  File "/home/freddy/gecko/python/mach/mach/main.py", line 523, in _run
    **vars(args.command_args))
  File "/home/freddy/gecko/python/mach/mach/registrar.py", line 101, in _run_command_handler
    assert isinstance(result, (int, long))

This seems bad.

Flags: needinfo?(sledru)
Component: General → Lint and Formatting
Flags: needinfo?(sledru)

Yeah, hg pull -u would give a better error message
and ./mach boostrap fix it :)

Status: NEW → RESOLVED
Closed: 6 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1543492
You need to log in before you can comment on or make changes to this bug.