Some items in panels can't be opened with the numpad's Enter key

RESOLVED FIXED in Firefox 68

Status

()

defect
P1
normal
RESOLVED FIXED
a month ago
27 days ago

People

(Reporter: itiel_yn8, Assigned: Gijs)

Tracking

(Blocks 1 bug)

unspecified
Firefox 68
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox68 fixed)

Details

Attachments

(1 attachment)

Reporter

Description

a month ago

STR:

  1. Lastet Nightly, Windows 10
  2. Open bugzilla.mozilla.org
  3. Click the Site Identity panel
  4. Navigate to Trackers, Cookies or Report a problem
  5. Hit the Enter key in the numpad

AR:
Nothing happens

ER:
Pressing the numpad's Enter key should open the respective panels.

I'm not sure atm if this is a regression from bug 1477673 or if this was an issue even before.

Reporter

Updated

a month ago
Has STR: --- → yes
Reporter

Updated

a month ago
Summary: Some items can't be opened with the numpad Enter button in the Site Identity panel → Some items can't be opened with the numpad's Enter key in the Site Identity panel

:itiel_yn8, if you think that's a regression, then could you try to find a regression range in using for example mozregression?

I very much doubt this is a regression, though I haven't tested it. The PanelMultiView code explicitly handles Enter, but not NumpadEnter (and this isn't something I changed):
https://searchfox.org/mozilla-central/source/browser/components/customizableui/PanelMultiView.jsm#1647

This should be a trivial fix, but needs tests.

Reporter

Comment 3

a month ago

This didn't work before anyway because of all of the 3 buttons didn't open using the normal Enter or the space key (bug 1539976, among the rest).

Assignee

Updated

28 days ago
Duplicate of this bug: 1545384
Assignee

Updated

28 days ago
Assignee: nobody → gijskruitbosch+bugs
Status: NEW → ASSIGNED
Summary: Some items can't be opened with the numpad's Enter key in the Site Identity panel → Some items in panels can't be opened with the numpad's Enter key
Priority: -- → P1

Comment 6

27 days ago
Pushed by gijskruitbosch@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/515cfc853f2a
add support for numpad enter key and add tests to check activation works, r=Jamie

Comment 7

27 days ago
bugherder
Status: ASSIGNED → RESOLVED
Last Resolved: 27 days ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 68
You need to log in before you can comment on or make changes to this bug.