WebM rendered skewed on macOS

VERIFIED FIXED in Firefox 67

Status

()

defect
VERIFIED FIXED
a month ago
25 days ago

People

(Reporter: denschub, Assigned: mstange)

Tracking

(Blocks 1 bug, Regression, {regression})

67 Branch
mozilla68
Points:
---

Firefox Tracking Flags

(firefox-esr60 unaffected, firefox66 unaffected, firefox67+ verified, firefox68+ verified)

Details

(URL)

Attachments

(6 attachments)

(Reporter)

Description

a month ago

This WebM is rendered with a 45 degrees skew on macOS in Nightly, see the attached screenshot. This works fine in Release and on Windows in Nightly. Running mozregression returned this push, and bug 1479145 jumps out as something that could be related.

Requesting tracking for 67 and 68, because the issue is reproducible in 67, and the patch in question got uplifted.

(Reporter)

Comment 1

a month ago

Markus, do you have an idea on what might cause this?

Flags: needinfo?(mstange)

This is very likely caused by bug 1479145.

Tracking for 67, if we can't get a fix before Beta 13 for this regression, we will back out bug 1479145 from beta.

(Assignee)

Comment 4

a month ago

This is a WebM with alpha information, so YUV->RGBA conversion is done on the CPU. We're not respecting the correct stride in that code path.

Assignee: nobody → mstange
Status: NEW → ASSIGNED
Flags: needinfo?(mstange)
(Assignee)

Comment 5

a month ago

Sorry Pascal, I mid-aired the tracking flag away.

(Assignee)

Comment 6

a month ago
Posted file test.html
(Assignee)

Comment 7

a month ago
Posted file reference.html
(Assignee)

Comment 9

a month ago

Depends on D27600

Comment 12

a month ago
Pushed by mstange@themasta.com:
https://hg.mozilla.org/integration/autoland/rev/cf3fbdaa46b9
Respect SharedRGBImage's stride during YUV->RGBA conversion. r=mattwoodrow
https://hg.mozilla.org/integration/autoland/rev/d5ac9681d3ce
Add a reftest. r=mattwoodrow
https://hg.mozilla.org/integration/autoland/rev/4ab1a110e5d5
Stub out SharedPlanarYCbCrImage::AdoptData because it can't be called without crashing, which means it's unused. r=mattwoodrow
https://hg.mozilla.org/integration/autoland/rev/185e608c3852
Remove unused method Image::GetBuffer(). r=mattwoodrow
(Assignee)

Updated

a month ago
Blocks: 1544877
(Assignee)

Updated

a month ago
Duplicate of this bug: 1542323
(Assignee)

Comment 16

a month ago

Comment on attachment 9058424 [details]
Bug 1544478 - Respect SharedRGBImage's stride during YUV->RGBA conversion. r?mattwoodrow

Beta/Release Uplift Approval Request

  • User impact if declined: Some videos (WebM with alpha) will be displayed with a skew on macOS
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): The fix is small and tightly-scoped, and applies to code which is only run for a certain type of video.
  • String changes made/needed:
Attachment #9058424 - Flags: approval-mozilla-beta?
(Assignee)

Updated

a month ago
Attachment #9058425 - Flags: approval-mozilla-beta?
Attachment #9058427 - Flags: approval-mozilla-beta?
Attachment #9058428 - Flags: approval-mozilla-beta?

Comment on attachment 9058424 [details]
Bug 1544478 - Respect SharedRGBImage's stride during YUV->RGBA conversion. r?mattwoodrow

The regression is very visible for a subset of our users and the patch looks safe and has tests. There is no request for manual QA while we have STR in comment #0, so let's ask for QA after landing on beta. Uplift accepted for 67 beta 13, thanks.

Attachment #9058424 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Flags: qe-verify+
Attachment #9058425 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Attachment #9058427 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Attachment #9058428 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
QA Whiteboard: [qa-triaged]

Reproduced the issue on 67.0b12 on Mac 10.13.6

Verified as fixed on Mac 10.13.6 on 67.0b13 and 68.0a1 20190424095359.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.