Closed Bug 1544509 Opened 1 year ago Closed 8 months ago

Google ad iframe not correctly load when we block fingerprinting domain voken.eyereturn.com

Categories

(Core :: Privacy: Anti-Tracking, defect)

Desktop
Windows 10
defect
Not set
normal

Tracking

()

RESOLVED WONTFIX
Tracking Status
firefox66 --- unaffected
firefox67 --- unaffected
firefox68 --- wontfix

People

(Reporter: david.sacal, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: regression)

Attachments

(1 file)

Affected versions:
68.0a1 (2019-04-15) (64-bit)

Affected platform:
Windows 10
Windows 7
Mac OS 10.14
Ubuntu 18.04

Steps to reproduce:
1.-Open the latest firefox nightly (https://nightly.mozilla.org)
2.-Download the latest flash beta version
http://labs.adobe.com/downloads/flashplayer.html
3.-Open www.addictinggames.com and let the site finish loading

Expected result:
The google iframe on the lower center of the screen is correctly shown.

Actual Results:
The google iframe on the lower center of the screen is transparent.

Note: firefox has the same behaviour without blocked content. Google Chrome shows the iframe correctly

Regression-range: will try to find it asap.

Component: Untriaged → Layout
Product: Firefox → Core

Could you attach the screenshot?

Flags: needinfo?(david.sacal)
Flags: needinfo?(david.sacal)

Hi,

The issue is also reproducible in latest nightly on Ubuntu 18.04

Can you try to find a regression range? I don't see the frame at all on Linux.

Flags: needinfo?(david.sacal)

Hi,
here is the link to the mozregression result. Please let me know if you need any other particular.

https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=98d4803bb2de7fcdb0096ddeedaefd29d0fd5fd4&tochange=3b08a133c893b960f15e014a8f36c954d31fda34

Regards
David

Flags: needinfo?(david.sacal)

I see the ad if I disable tracking protection. I think this is working as expected, but I assume this is a regression from bug 1525458.

ni? Ehsan just to confirm, but I think this is INVALID as it is unless you also don't see the ad if you disable tracking protection.

Component: Layout → Privacy: Anti-Tracking
Flags: needinfo?(ehsan)
Regressed by: 1525458
Flags: needinfo?(ehsan)
No longer regressed by: 1525458
Summary: Google iframe not correctly load or transparent → Google ad iframe not correctly load when we block fingerprinting domain voken.eyereturn.com
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → INVALID

Ehsan, this bug looks invalid to me. Do you have a different opinion?

Status: RESOLVED → REOPENED
Resolution: INVALID → ---

Bugbug thinks this bug is a regression, but please revert this change in case of error.

Keywords: regression

Ehsan - Can we close this one out as invalid?

Flags: needinfo?(ehsan)

In what sense is this bug invalid, I'm not sure if I understand? When I looked at the bug, if my recollection is right, we were blocking a fingerprinting domain and that was resulting in an ad on the site getting blocked in some cases. Please note that our fingerprinting blocking feature isn't intended to be an ad blocker.

Whether or not we want to fix it is a different question. :-) Steven, do we have any evidence that this bug affects a lot of websites? Do you have any thoughts here?

Flags: needinfo?(ehsan) → needinfo?(senglehardt)

(In reply to :Ehsan Akhgari from comment #11)

In what sense is this bug invalid, I'm not sure if I understand? When I looked at the bug, if my recollection is right, we were blocking a fingerprinting domain and that was resulting in an ad on the site getting blocked in some cases. Please note that our fingerprinting blocking feature isn't intended to be an ad blocker.

Whether or not we want to fix it is a different question. :-) Steven, do we have any evidence that this bug affects a lot of websites? Do you have any thoughts here?

Hello Ehsan - We reviewed this bug during platform triage and were keying off Comment 8. Happy to keep it open - we were just trying to move it forward :)

During manual testing done by QA (Mozilla-only doc) we found that a total of 36 out of the 900 websites tested had missing advertisements. This count includes all domains currently on the fingerprinting blocklist. We determined this to be an acceptably low impact for the protection provided.

Status: REOPENED → RESOLVED
Closed: 1 year ago8 months ago
Flags: needinfo?(senglehardt)
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.