java.lang.NullPointerException: Attempt to invoke interface method 'void org.mozilla.geckoview.GeckoSession$HistoryDelegate.onHistoryStateChange(...)' on a null object reference

RESOLVED FIXED in Firefox 68

Status

defect
RESOLVED FIXED
2 months ago
2 months ago

People

(Reporter: snorp, Assigned: snorp)

Tracking

({regression})

unspecified
mozilla68
Unspecified
Android

Firefox Tracking Flags

(firefox66 unaffected, firefox67 unaffected, firefox68 fixed)

Details

(Whiteboard: [bcs:p1])

Attachments

(1 attachment, 1 obsolete attachment)

04-15 14:46:11.112 28514 28514 E AndroidRuntime: java.lang.NullPointerException: Attempt to invoke interface method 'void org.mozilla.geckoview.GeckoSession$HistoryDelegate.onHistoryStateChange(org.mozilla.geckoview.GeckoSession, org.mozilla.geckoview.GeckoSession$HistoryDelegate$HistoryList)' on a null object reference
04-15 14:46:11.112 28514 28514 E AndroidRuntime: at org.mozilla.geckoview.GeckoSession$4.handleMessage(GeckoSession.java:613)
04-15 14:46:11.112 28514 28514 E AndroidRuntime: at org.mozilla.geckoview.GeckoSession$4.handleMessage(GeckoSession.java:588)
04-15 14:46:11.112 28514 28514 E AndroidRuntime: at org.mozilla.geckoview.GeckoSessionHandler.handleMessage(GeckoSessionHandler.java:78)
04-15 14:46:11.112 28514 28514 E AndroidRuntime: at org.mozilla.gecko.EventDispatcher$3.run(EventDispatcher.java:368)
04-15 14:46:11.112 28514 28514 E AndroidRuntime: at android.os.Handler.handleCallback(Handler.java:873)
04-15 14:46:11.112 28514 28514 E AndroidRuntime: at android.os.Handler.dispatchMessage(Handler.java:99)
04-15 14:46:11.112 28514 28514 E AndroidRuntime: at android.os.Looper.loop(Looper.java:193)
04-15 14:46:11.112 28514 28514 E AndroidRuntime: at android.app.ActivityThread.main(ActivityThread.java:6669)
04-15 14:46:11.112 28514 28514 E AndroidRuntime: at java.lang.reflect.Method.invoke(Native Method)
04-15 14:46:11.112 28514 28514 E AndroidRuntime: at com.android.internal.os.RuntimeInit$MethodAndArgsCaller.run(RuntimeInit.java:493)
04-15 14:46:11.112 28514 28514 E AndroidRuntime: at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:858)

I get this in FxR, presumably because they don't hook up a history delegate.

Duplicate of this bug: 1544498
Attachment #9058384 - Attachment is obsolete: true
Keywords: regression
OS: All → Android
Whiteboard: [bcs:p1]
Attachment #9058386 - Attachment description: Bug 1544542 - Don't try to call history delegate if we don't have one r?droeh → Bug 1544542 - Don't try to call history delegate if we don't have one

Comment 4

2 months ago
Pushed by jwillcox@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/1eec26ba4a75
Don't try to call history delegate if we don't have one r=droeh

Comment 5

2 months ago
bugherder
Status: NEW → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla68
Assignee: nobody → snorp
You need to log in before you can comment on or make changes to this bug.