about:support copy text function copies hidden sections which show up when pasting in e.g. textedit

VERIFIED FIXED in Firefox 68

Status

()

defect
P3
normal
VERIFIED FIXED
2 months ago
11 days ago

People

(Reporter: Gijs, Assigned: Gijs)

Tracking

Trunk
mozilla68
Points:
---

Firefox Tracking Flags

(firefox68 verified)

Details

Attachments

(1 attachment)

Assignee

Description

2 months ago

There's a no-copy class, but the code at https://searchfox.org/mozilla-central/rev/1b2636e8517aa48422ed516affe4d28cb7fa220a/toolkit/content/aboutSupport.js#968-971 just ignores it and copies the entire page contents. It also ignores it for text, but there perhaps the Serializer saves our bacon by ignoring hidden elements, or something.

As an example, this affects the "user.js Preferences
Your profile folder contains a user.js file, which includes preferences that were not created by Firefox." section (ie it shows up even if you don't have a user.js file).

I'm not sure I'm seeing what you're seeing, or understand what this is referring to. I have clicked "Copy text to clipboard" and pasted in a text editor and all I see are things that show up in about:support and seem reasonable to copy out.

Could you clarify the STR?

Flags: needinfo?(gijskruitbosch+bugs)
Assignee

Comment 2

2 months ago

Yep! Steps from mac:

  1. start with clean profile
  2. open about:support
  3. click 'copy text to clipboard'
  4. open textedit.app and a new doc in there
  5. ensure in the Format menu that rich text is enabled
  6. paste in the new doc

I'm assuming that with these steps this is reproducible, though it'd be fun (for some meaning of the word) if you see something else. :-)

Flags: needinfo?(gijskruitbosch+bugs) → needinfo?(dothayer)

Hmm, yeah I can reproduce this on Mac. I can't reproduce with pasting in WordPad on Windows, though. Given the importance of about:support pasting for bug reporting I'm going to P3 this.

Flags: needinfo?(dothayer)
Priority: -- → P3
Assignee

Updated

2 months ago
Assignee: nobody → gijskruitbosch+bugs
Status: NEW → ASSIGNED

Comment 5

2 months ago
Pushed by gijskruitbosch@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/d0943c0f7615
fix about:support copy/paste implementation to correctly ignore no-copy elements, r=dthayer

Comment 6

2 months ago
bugherder
Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla68
Flags: qe-verify+

Reproduced: Fx 68.0a1 (2019-04-16) - Windows 10 x64
Verified fixed: Fx 69.0a1 (2019-06-05) and Fx 68.0b7 - Windows 10 x64, Ubuntu 18.04 x64, macOS 10.13

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.