Streamline the "Make Firefox your default browser" user settings workflow

VERIFIED FIXED in Firefox 67

Status

()

defect
P1
normal
VERIFIED FIXED
4 months ago
3 months ago

People

(Reporter: cpeterson, Assigned: diana.iacos)

Tracking

unspecified
Firefox 68
All
Android
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox66 wontfix, firefox67 verified, firefox68 verified)

Details

(Whiteboard: [bcs:p2])

Attachments

(3 attachments, 1 obsolete attachment)

The current steps to make Fennec your default Android browser:

  1. Open Fennec hamburger menu.
  2. Tap Settings menu item.
  3. Scroll to the bottom of the Settings menu list.
  4. Tap "Make default browser"
  5. Android will open the "Default apps" system settings menu.
  6. Tap the "Browser app" menu item.
  7. Tap the "Firefox" menu item.

Fennec is now your default browser, but that's a lot of steps!

TBD:

  • Can Fennec use some Android intent magic to open the "Browser app" system settings menu directly instead of the "Default apps" system settings menu?

  • Should we rename the "Make default browser" menu item to something friendlier like "Make Firefox your default browser"?

  • Can we dynamically move the "Make default browser" menu item to the top of the Settings menu list if Fennec is not currently the default browser? When Fennec is the default browser, we can move the "Make default" menu item to the bottom of the Settings menu list.

  • If we can't dynamically reorder the Settings menu items, maybe we can just move the "Make default browser" menu item up a few entries (above "Clear private data" or "Advanced") so it is visible on screen without scrolling. Moving the menu item would not require any localization, so it would be easy to uplift to 67 Beta.

Devin, here is another Fennec bug we'd like Softvision to investigate.

Flags: needinfo?(dreams)

To answer your questions:

  • Can Fennec use some Android intent magic to open the "Browser app" system settings menu directly instead of the "Default apps" system settings menu?
    This is the only intent available, to open default app settings, but not specifically a section of that list.
    And it is only available on API 24+ - https://developer.android.com/reference/android/provider/Settings#ACTION_MANAGE_DEFAULT_APPS_SETTINGS
    Below that we just direct users to a SUMO page that details the process of setting the default browser

  • Should we rename the "Make default browser" menu item to something friendlier like "Make Firefox your default browser"?
    Easy change. Need Product input on the updated title.

  • Can we dynamically move the "Make default browser" menu item to the top of the Settings menu list if Fennec is not currently the default browser? When Fennec is the default browser, we can move the "Make default" menu item to the bottom of the Settings menu list.

  • If we can't dynamically reorder the Settings menu items, maybe we can just move the "Make default browser" menu item up a few entries (above "Clear private data" or "Advanced") so it is visible on screen without scrolling. Moving the menu item would not require any localization, so it would be easy to uplift to 67 Beta.
    How about having that menu option to the top of the Settings menu list by default, and if the browser is already default we could hide that option altogether?

We currently have a cool Leanplum experiment that proactively presents the users with the option to make Fennec the default browser (if not already) - https://drive.google.com/file/d/1cu9j19rhu-YAbwIN2pX3ETryIpqKjpoY
Maybe this can be tweaked by Marketing / made available to all users.

Thank you, Petru. Andreas, want to chat more to weigh some of these options?

Flags: needinfo?(dreams) → needinfo?(abovens)

Here are some things I suggest we do.

  1. As suggested above, inside Firefox Settings, change "Make default browser" into "Make $Firefox your default browser" (where $Firefox is the app name: "Nightly", "Firefox Beta", "Firefox")

  2. Move the "Make $Firefox your default browser" option in Firefox Settings to the top, just below "Firefox Account" and above "General".

  3. The "Make $Firefox your default browser" option should only be shown if no default browser is set, or if a different browser is set as default. If $Firefox is the default, this option shouldn't be shown in Settings.

  4. a) If no default browser is set, tapping on "Make $Firefox your default browser" should trigger the "Open with" intent screen, which lists all installed browser and allows them to set this choice "Just once" / "Always".
    b) If another default browser is set, tapping on "Make $Firefox your default browser" should trigger the "Default apps" Android Settings screen, from which a user can pick a default Browser app.

  5. When showing the "Default apps" Android Settings screen, we should show a toast message (https://developer.android.com/guide/topics/ui/notifiers/toasts) explaining what needs to happen. Suggestion: "Tap Browser App & select $Firefox"

Extra:

  • show a mini overlay guide animation describing what to do in scenarios 4a and 4b. In case 4b is implemented, the toast message described in 5 is no longer needed. This particular feature will need UX input and graphic design.

CCing James for reference and possible input.

Flags: needinfo?(abovens) → needinfo?(jkeller)
Priority: -- → P1

(In reply to Andreas Bovens [:abovens] from comment #4)

  1. a) If no default browser is set, tapping on "Make $Firefox your default browser" should trigger the "Open with" intent screen, which lists all installed browser and allows them to set this choice "Just once" / "Always".

Andreas, what is the "Open with" intent screen? Are you suggesting that tapping "Make $Firefox your default browser" will try to open a URL in order to purposely trigger Android's list of installed browsers?

  1. When showing the "Default apps" Android Settings screen, we should show a toast message (https://developer.android.com/guide/topics/ui/notifiers/toasts) explaining what needs to happen. Suggestion: "Tap Browser App & select $Firefox"

Can we make the toast message appear after the "Default apps" screen has been opened? The user could then see our "Tap Browser App & select $Firefox" instructions and the Browser App menu item on screen at the same time.

Petru, we should add an L10n code comment to inform translators that "Browser App" is the name of Android's menu item, so they should use the same menu name translation as Android.

Extra:

  • show a mini overlay guide animation describing what to do in scenarios 4a and 4b. In case 4b is implemented, the toast message described in 5 is no longer needed. This particular feature will need UX input and graphic design.

This animation sounds like a lot of extra work for our short schedule. I think the 4b toast message's instructions are clear enough. :)

Flags: needinfo?(abovens)
Assignee: nobody → petru.lingurar
Status: NEW → ASSIGNED

(In reply to Chris Peterson [:cpeterson] from comment #5)

(In reply to Andreas Bovens [:abovens] from comment #4)

  1. a) If no default browser is set, tapping on "Make $Firefox your default browser" should trigger the "Open with" intent screen, which lists all installed browser and allows them to set this choice "Just once" / "Always".

Andreas, what is the "Open with" intent screen? Are you suggesting that tapping "Make $Firefox your default browser" will try to open a URL in order to purposely trigger Android's list of installed browsers?

Yes, that's pretty much what needs to happen I think: I'd like to see what is shown in open-with.jpg - we can point to www.mozilla.org/firefox/mobile for instance. Other suggestions are welcome.

  1. When showing the "Default apps" Android Settings screen, we should show a toast message (https://developer.android.com/guide/topics/ui/notifiers/toasts) explaining what needs to happen. Suggestion: "Tap Browser App & select $Firefox"

Can we make the toast message appear after the "Default apps" screen has been opened? The user could then see our "Tap Browser App & select $Firefox" instructions and the Browser App menu item on screen at the same time.

Yes, that's the idea. It is possible afaik.

Petru, we should add an L10n code comment to inform translators that "Browser App" is the name of Android's menu item, so they should use the same menu name translation as Android.

Extra:

  • show a mini overlay guide animation describing what to do in scenarios 4a and 4b. In case 4b is implemented, the toast message described in 5 is no longer needed. This particular feature will need UX input and graphic design.

This animation sounds like a lot of extra work for our short schedule. I think the 4b toast message's instructions are clear enough. :)

That's indeed the most realistic scenario. But one can dream ;)

Flags: needinfo?(abovens)
Assignee: petru.lingurar → diana.iacos
Attachment #9060407 - Attachment is obsolete: true

Pushed by csabou@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/a644a4296edf
Streamline the "Make Firefox your default browser" user settings workflow; r=petru
https://hg.mozilla.org/integration/autoland/rev/70bcbf68e7d8
Refactor isDefaultBrowser out from MmaDelegate to PackageUtil; r=petru

Keywords: checkin-needed
Status: ASSIGNED → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 68
Depends on: 1546889

I've verified that the new "Make Nightly your default browser" menu item works correctly in Fennec Nightly.

Status: RESOLVED → VERIFIED
Flags: needinfo?(jkeller)

Comment on attachment 9060406 [details]
Bug 1544589 - Streamline the "Make Firefox your default browser" user settings workflow; r?petru

Beta/Release Uplift Approval Request

  • User impact if declined: Fennec 67 will be released with a less intuitive "Make Firefox your default browser" workflow for the Fennec EU Browser Choice screen.
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: No
  • If yes, steps to reproduce: 1. Open Fennec's settings menu.
  1. See the "Make Nightly your default browser" menu item.
  2. Tap the "Make Nightly your default browser" menu item.
  3. See the "Tap Browser app & select Nightly" toast message.
  • List of other uplifts needed: None
  • Risk to taking this patch: Medium
  • Why is the change risky/not risky? (and alternatives if risky): Risk from refactoring some UI code and adding a new string. This patch is the first in a series to be landed in a specific order.
  • String changes made/needed: New string pref_default_browser2 "Make &brandShortName; your default browser", but I've been coordinating with the L10n team and the new string has been localized to 34+ languages.
Attachment #9060406 - Flags: approval-mozilla-beta?
Attachment #9060430 - Flags: approval-mozilla-beta?

Comment on attachment 9060406 [details]
Bug 1544589 - Streamline the "Make Firefox your default browser" user settings workflow; r?petru

Uplift approved for 67 beta 15, thanks.

Attachment #9060406 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Attachment #9060430 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Flags: qe-verify+

Hello, I can confirm that this ticket is verified on the latest version of Nightly 68.0a1 (2019-04-29) and Beta 67.0b15 using Nexus 6P (Android 8.1.0) and Nokia 6 (Android 7.1.1). Due to that, I'll remove the qe-verify flag, thanks.

Flags: qe-verify+
OS: Unspecified → Android
Hardware: Unspecified → All
See Also: → 1548000
Attachment #9060407 - Attachment is obsolete: false
Attachment #9060407 - Attachment is obsolete: true
See Also: → 1552545
You need to log in before you can comment on or make changes to this bug.