Closed Bug 1544699 Opened 9 months ago Closed 9 months ago

browser_allocations_target.js isn't running on autoland

Categories

(DevTools :: Framework, defect)

defect
Not set

Tracking

(firefox68 fixed)

RESOLVED FIXED
Firefox 68
Tracking Status
firefox68 --- fixed

People

(Reporter: ochameau, Assigned: ochameau)

References

Details

Attachments

(1 file)

I think it comes from the skip-if:
https://searchfox.org/mozilla-central/source/devtools/client/framework/test/allocations/browser_allocations_target.ini#10

skip-if = os != 'linux' || debug || asan || pgo # Results should be platform agnostic - only run on linux64-opt

Which I copied from the inspector metrics test:
https://searchfox.org/mozilla-central/source/devtools/client/framework/test/metrics/browser_metrics_inspector.ini#12

But all other metrics test do not skip pgo.

And if you look at autoland, you can see all metrics tests. All but inspector:
https://treeherder.mozilla.org/#/jobs?repo=autoland&searchStr=mochitest%2Cdevtools%2Clinux&selectedJob=240583159

It isn't clear why the inspector test is skipped for pgo (via bug 1502791), but not running on autoland builds will make it harder to bisect regressions.

It looks like the default builds on autoland branch are PGO,
so accept running these tests on pgo to have them running on autoland.

Pushed by apoirot@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/4ff27e3a312b
Run allocations and metrics tests on pgo builds. r=jdescottes
Status: NEW → RESOLVED
Closed: 9 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 68
Assignee: nobody → poirot.alex
You need to log in before you can comment on or make changes to this bug.