no results on nytimes.com

VERIFIED FIXED in Firefox 68

Status

defect
VERIFIED FIXED
2 months ago
2 months ago

People

(Reporter: mbalfanz, Assigned: yzen)

Tracking

(Blocks 1 bug)

65 Branch
Firefox 68
Dependency tree / graph

Firefox Tracking Flags

(firefox68 verified)

Details

Attachments

(2 attachments)

Reporter

Description

2 months ago

STR:

ER:

  • the audit should show plenty of nodes as the light-grey timestamps below articles are low contrast

AR:

  • the resulting accessibility tree is blank

On a sidenote:

  • when you use the picker to select a timestamp, it shows the low contrast and correctly places a badge in the accessibility tree
  • when you then click the badge, it disappears
  • after a few seconds, the tree will be filtered down and only show the node that you clicked the badge on
Reporter

Comment 1

2 months ago

Something similar happens on http://designernews.co/

In the video attached, I first run the audit through the toolbar => no results.

Then I use the picker to hover over the new bubble => the node gets added to the result list.

Assignee

Updated

2 months ago
Assignee: nobody → yzenevich
Status: NEW → ASSIGNED

Comment 3

2 months ago
Pushed by yura.zenevich@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/9dafc71a1f37
ensure that the contrast ratio check required stylesheet does not get removed while calculating contrast. r=pbro

Comment 4

2 months ago
bugherder
Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 68

Comment 5

2 months ago

We could not reproduce this issue anymore on the latest Nightly on Windows 10, Mac OS 10.14 and Ubuntu 18.04.
Full page audit will work for both NYtimes and DesignerNews.
Martin, can you please check that out too?

Closing this as Verified - Fixed but please do re-open it if needed!

Status: RESOLVED → VERIFIED
Flags: needinfo?(mbalfanz)
Reporter

Comment 6

2 months ago

Works for me 👍

Flags: needinfo?(mbalfanz)
You need to log in before you can comment on or make changes to this bug.